No wifi device, ubuntu server after copy all AP6255 files to /lib/firmware/brcm

As subject, i installed ubuntu server 20.04 to ROCK Pi X (wifi version), then unzip the AP6225(WiFi & BT Firmware) files to /lib/firmware/brcm and reboot…

I also not found wifi device, just ethernet and loopback only…

enp1s0: unmanaged
“Realtek RTL8111/8168/8411”
ethernet (r8169), 00:E0:4C:88:05:E5, hw, mtu 1500

lo: unmanaged
loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

Any one could help? Thank you…

Depending on the kernel version in use you should download and use wifi firmware from

ls -la  /usr/lib/firmware/brcm/brcmfmac43455-sdio.bin*
-rw-r--r-- 1 root root 488193 Dec  9 22:10 /usr/lib/firmware/brcm/brcmfmac43455-sdio.bin

Assuming you have some experience with ubuntu you should immediately debloat the “server” if you want it lean and mean. Remove Cloud, snap, and all unnecessary services and reduce journaling if you want your eMMC to last longer.


avaf, thanks for response, as your advise, if i make this device and put it on production, i will remove unnecessary services and disk IO.

about this problem, i checked the dmsg and found it can’t load brcmfmac43455-sdio.txt:

brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.txt failed with error -2

this case look like happen on raspberry pi. i made a copy of ‘brcmfmac43455-sdio.ROCK Pi-ROCK Pi X.txt’ and named it ‘brcmfmac43455-sdio.txt’, then reboot.

the wireless interface “wlan0” could work now. :wink:

Hi @gordonlukch
I faced with similar problem, but in CentOS7.
I tried your solution, renamed ‘brcmfmac43455-sdio.ROCK Pi-ROCK Pi X.txt’ to ‘brcmfmac43455-sdio.txt’. But WiFi adapter is still not found.
When you unziped the AP6225, did you copy(to /lib/firmware/brcm) bt and wifi directories, or files inside they?

Best regards

I unzip and copy whole directory to /lib/firmware/brcm, then make a copy of the .txt and rename it as previous mentioned. Wish can help you~