No Wifi available on Debian/Ubuntu on Pi 4B+

Hi,

After installation of the latest image of Debian 10 Desktop (or Ubuntu 20.04 server) on a SD card, system boots but Wifi is not available.

Boot shows a message about a ap6256 chip, but some warnings follow.
Finally, trying to activate the wifi from the advised commands (nmcli r wifi on; nmcli dev wifi; nmcli dev wifi connect “xxx” passwrod “yyy”) ends on error ‘No Wi-Fi device found’.

How can I solve this problem?

Thank You

Revision of PCB is v1.73, quite new compared to the available distros Ubuntu/Debian. Could this be an explanation?
The device still does not work after the recent attempts to update/upgrade the distros from the regular repositories.

I´ve got the same problem. Using a Rock Pi 4+ V1.73 with the latest desktop image from this side, but wifi is not working.

No wlan0 device.

I need help.

Same for me ?

I have the same Issue im on the latest Ubuntu and the wlan0 is disabled and I cant get it on ?

wlan0: unavailable
    "Broadcom Wi-Fi"
    wifi (bcmsdh_sdmmc), B8:13:32:4A:46:0E, hw, mtu 1500

Fixed it i think i hade the wrong image

Can you share how you fixed this?

One solution is to download correct image - read text (!) before clicking download button - https://www.armbian.com/rockpi4/
For stock images - never used it - don’t know.

@igorp We were complaining about the official Ubuntu and Debian flavors. Yes, I will try this Armbian version, although I must admit that since I acquired the rock 5b, my interest in solving this Wifi problem dropped. I will post the result of this attempt to confirm :wink: Thanks

@m99 as You mentioned You probably had the wrong image, do You mean You only tried the stock Debian/Ubuntu downloads from Radxa or something else to solve the issue? Thanks

We’re in the same boat - using the official Radxa Ubuntu Server image and haven’t been able to find anything to get wifi going. I’m mainly a Windows programmer so I’m pretty new and trying to learn as much as I can. So if anyone has gotten wifi on Unbuntu Server going, please share! :slightly_smiling_face: Thanks!!

Why do you insist in official (but fake) Ubuntu? Nobody prevents you to try official Armbian, which support hardware makers and their consumers with ready to run OS and ready to run build software. If still nothing works for you, you can build from sources and add the driver you need / is missing. Hoping that HW maker will cover every detail & problem in Linux OS is IMO a bit too much to expect.