New Rock5 - First steps, first problems: random reboots and ubuntu updates not working

Hi there!
I just onboxed and setup my new rock5: sooo sweet!
I managed to get ubuntu installed (official radxa image) onto my nvme and its booting from it.
SPI-IMAGE: rock-5b-spi-image-g49da44e116d.img
LOADER: rk3588_spl_loader_v1.08.111.bin
config: rock-5b-spinor.cfg from rkdev v2.96
ubuntu: rock-5b-ubuntu-focal-server-arm64-20221031-1328-gpt.img

Also installed the fan control for the “stock” fan:
fan is spinning and doing what its supposed to do.

However, i am experiencing a very annoying issue: The device randomly reboots.

  • Powersupply and cable is from allnet, so must be appropriate.
  • I monitored temps: thats not it: last refresh in ssh shows 34.2 °C for all temp sensors.

Also, there seem to be problems with the apt repository from radxa:

Can somebody help?

Kind regards

After reboot there is a kernel message on console:
rk-pcie fe170000: PCIe Link Fail
rk-pcie fe170000: failed to initialize host

1 Like

I cannot help much but I have the same kind of error messages but with another address:
2022-11-25T11:16:40.160491+00:00 rock-5b-001 kernel: [ 7.123212] rk-pcie fe150000.pcie: PCIe Link Fail 2022-11-25T11:16:40.160493+00:00 rock-5b-001 kernel: [ 7.123219] rk-pcie fe150000.pcie: failed to initialize host
All working fine for me.

export DISTRO=focal-stable
wget -O -$DISTRO/public.key | sudo apt-key add -
sudo apt-get update

I’ve also encountered the reboot problem and I think it’s due to the incompabitle pd power source. I’ve tried 3 different pd power sources, the one from allnet and the other showed me good performance (no random reboot), while the last one drives me crazy by rebooting rock pi 5b every several minutes.

I have the same problem. Allnet PD power supply makes rock 5b reboot each couple of hours. I have now running on baseus PD for like a whole week and no reboots!

Thanks for all the replies! I contacted allnet to get my power supply replaced, sadly nobody is responding to my email.
Does anybody know if there is a dedicated support contact?
i replied to

Kind regards

1 Like

Chinese new year. Most of them should be spending time with their families. Work should restart from the next week.

This board will work only with “official” distro published by Radxa but with caution: for example with Ubuntu if you correct the NO_PUBKEY error and after that do apt update, when you reboot the board loop and nothing appens. I tried several times, also with different PD, same result.
The same with unofficial distros.
I think it is unacceptable.

Well, its been several months: its still not working with the official power supply.
Its just collecting dust and cant get used for anything.
I hope this gets fixed soon, i am disappointed.

I bought a Ugreen 65W because the one bought from allnetchina fizzes. This cost to me 40 euro.
Well, as you my board is just collecting dust because it works only with official distros without any changes, if you do some update and so on, the board going into boot loop. No way with other distros, never boot.
Unfortunately it is too late to return all the material purchased (also bought a nvme…).

Permanent solution for reboots (power supply) = Samsung 45W.
No issues at all, zero problems ever.

I have no problems with Ugreen 65W CD244 with Armbian. Boot from microSD, system on NVME. Updates also not break boot

1 Like

Mine is UGREEN Caricatore USB C 65W GaN Tech.

I have reboot trouble too. I am on de original radxa power supply and i flashed bios so i can boot from nvme and i’m running armbian.
What should i do?

Use what @DarkevilPT suggested or a fixed 12V power supply.

1 Like

Interesting, which one you have? I have the “RADXA POWER PD 30W” (bought from Allnet.China) and it works very well with both of my 5B’s, powers one together with a Samsung 970 NVME and a passive USB 3.1 hub (and switches voltage from 5 to 12V as expected)


However, the “PD 45W power supply with USB-C connector” that was offered when I bought the 5B suffers from the “too long until kernel boots => power reset” problem, like my USB-C power port on the monitor (and all other PD supplies I tried).

It is indeed the RADXA POWER PD 30W and i have reboots.
I think that is not a good sign for me. It might be the board or something.
Could the amount of memory be part of the problem? More mem=more power?
I have the 16gb model

I have 16G, and a NVME SSD, and an external USB 3.1 hub, and both HDMI outputs on, so I don’ think so. The core of the problem is the long time the Linux kernel needs to boot up. Most PD just “see an timeout” and reset the power, causing a boot loop. If you have a USB power-meter, you can see that effect.

Hence, either your boot process is to slow even for the Radxa adapter, or the Radxa PD hardware can be different… Where do you load the kernel from?

To be honest, I have 4 Radxa adapters, but tried only two of them, maybe I should look if they are different. That said, my board also works with a “dump” Argon40 adapter, which deliveres 5V 4A. My powermeter shows the 5B switches the Radxa PD to 12V and uses not more than 19W under full load, so this should be also be fine. A 5V 3A (from RPi for instance) might be not (for my case).

There is a thread (I could not find) from @balbes150 containing patches to u-boot to switch the PD to 12V from there. Theoretically, this could be the right solution for all PD blocks that does not work yet.

I’m not in a bootloop. I am in a bootloop with other power adapters. My system boots up, and then just reboots randomly or locks at random times. It can work for to a few minutes up to a few days. Tried lowering max frequency, which ‘seems’ to make it reboot less frequently but it does not solve the problem.

Ah, sorry, got that wrong. Mine runs “rock solid”, 24/7 for weeks, I reboot only for necessary updates. Have you checked temperature? I have the Radxa passive shell, and temperature goes up to 70°C for long lasting compile for instance. That said, I had locks with one of my fixed 5V adapters, but can’t remember which it was, maybe the 5V 3A one …