New Rock 4C+ no longer able to boot - solid green light + no blue light/drive activity

I just received a new Rock PI 4C+ from Allnet and have spent the past 2 days trying to get this thing working.

Since the beginning, the board would not boot from two different SD Cards (I tried the latest Radxa Debian and Ubuntu images from github - rock-4c-plus-debian-bullseye-xfce4-arm64-20221201-1146-gpt for example). The Radxa Debian images booted twice into desktop, but then the desktop crashed and the board would no longer boot. I also tried Armbian (Debian version from 12-2022 booted, but could not proceed due to kernel panics - THEN, after this, the board would not boot from Armbian) and Generic Manjaro.

Now, the board won’t boot no matter what I do. I have tried the following to resolve:

  • Tried switching power supplies (am using a 5V/4A SBC USB-C charger outputting 20 watts). Also tried two other chargers with 5V/3A - behavior did not change.
  • Used two different SD cards (one is brand new from Kingston) to make sure my main SD card isn’t borked.
  • Used different distros (Radxa Debian, Armbian/Debian, Manjaro). Only Radxa/Debian and Armbian booted, but then crashed (Radxa booted to desktop then crashed/froze when opening the browser, and Armbian started the boot process but crashed with kernel panics). After the crashes, the board stopped booting at all.
  • Tried switching around my peripherals across the different USB ports, nothing changed
  • Used Etcher to flash the SD Cards, but also tried the stock Debian Desktop image flasher from my other PCs. No differences.

The board’s behavior now: once power is connected, the solid green “power” light is seen, but NO blue light/drive activity. The yellow ethernet LED flashes intermittently. The heat sinks on the CPU is slightly warm, but not hot or overheated whatsoever.

I have spent hours searching for this issue on these forums, reddit, and even the Armbian forums and have tried everything I found. I am unsure at this point whether or not my board is defective or damaged somehow.

Any and all assistance would be appreciated, thank you!

For what it’s worth, attached is a screenshot for when I was able to get Armbian booting (before kernel panicking, then freezing, then having the board being no longer able to boot at all).