New Radxa Zero - Does not boot cannot install linux on EMMC

I just got my Radxa Zero yesterday and having issues turning it on. I plugged in a monitor, keyboard and a mouse thinking the EMMC should have android in it it should just boot up. It did not and I thought probably i was wrong.

So I connected to the computer following the maskrom guide (pressing the usb-boot button and plug the cable). I can see the board on lsusb

Bus 003 Device 014: ID 1b8e:c003 Amlogic, Inc. GX-CHIP

So I proceeded to erase the EMMC following the guide and installed pyamlboot and then downloaded the radxa-zero-erase-emmc.bin rz-udisk-loader.bin.

Then I am trying to load the rz-udisk-loader.bin into the emmc using the I am presented with an error

(env) [bhashithe@desktop Downloads]$ sudo rz-udisk-loader.bin 
[sudo] password for bhashithe: 
Firmware Version :
ROM: 3.2 Stage: 0.0
Need Password: 0 Password OK: 1
Writing rz-udisk-loader.bin at 0xfffa0000...
Running at 0xfffa0000...
AMLC dataSize=16384, offset=65536, seq=0...
AMLC dataSize=49152, offset=393216, seq=1...
AMLC dataSize=16384, offset=229376, seq=2...
AMLC dataSize=49152, offset=245760, seq=3...
Traceback (most recent call last):
  File "/home/bhashithe/env/bin/", line 57, in <module>
    dev.writeAMLCData(seq, offset, data[offset:offset+length])
  File "/home/bhashithe/env/lib/python3.10/site-packages/pyamlboot/", line 462, in writeAMLCData
    self._writeAMLCData(amlcOffset, amls)
  File "/home/bhashithe/env/lib/python3.10/site-packages/pyamlboot/", line 416, in _writeAMLCData
    data =, 1000)
  File "/home/bhashithe/env/lib/python3.10/site-packages/usb/", line 423, in read
    return, size_or_buffer, timeout)
  File "/home/bhashithe/env/lib/python3.10/site-packages/usb/", line 1029, in read
    ret = fn(
  File "/home/bhashithe/env/lib/python3.10/site-packages/usb/backend/", line 846, in bulk_read
    return self.__read(self.lib.libusb_bulk_transfer,
  File "/home/bhashithe/env/lib/python3.10/site-packages/usb/backend/", line 954, in __read
  File "/home/bhashithe/env/lib/python3.10/site-packages/usb/backend/", line 604, in _check
    raise USBError(_strerror(ret), ret, _libusb_errno[ret])
usb.core.USBError: [Errno 5] Input/Output Error

I have seen this issue on other forum posts, which I saw that this was due to a hardware issue and the had to return the radxa zero, I am hoping this is not the case with mine, but it looks like it is. I have tried load various .bin and .img (android) files into the EMMC which leads to the same issue.

Any help would be appreciated.

EDIT: I have also installed libusb which did not solve the issue

USB error looks like a hardware communication issue. Can you check your kernel dmesg -c when having above issue? Or try with another USB cable or USB port?

@jack thank you, i started with your suggestions and changed the USB port of my host computer. It was initially plugged into a USB 3.0 port since that was suggested in one of the wiki. But when I changed it to a USB2.0 port it worked okay.

I have now installed Debian and set up a screen and other peripherals. I will try other OSs as well, want to play retro games on this.