New OSes images

I can see that there are new images of OSes available. What change do they provide, what news?

Is it crucial to upgrade to these images or standard apt update/upgrade is enough?

It looks like the Ubuntu Server edition is new.
That’s the one I use.
I too would like to know what the changes are.
Maybe a change log when existing images are updated?


There is a wiki page for that.

Jack always has the answer :slight_smile:

I have previous OS version, previous image.
I have these files in /boot folder:


/boot/extlinux/extlinux.conf looks like this:

label kernel-4.4
kernel /Image
fdt /rockpi-4b-linux.dtb
append earlyprintk console=ttyFIQ0,1500000n8 rw root=PARTUUID=b921b045-1d rootfstype=ext4 init=/sbin/init rootwait

How should I change its content to use the newer kernel?

To upgrade from previous images:

Add the radxa apt first if you haven’t and install the latest rockchip-overlay

sudo apt-get install --only-upgrade rockchip-overlay

Install the latest u-boot

sudo apt-get install rockpi4b-rk-ubootimg

Manually run the u-boot flash script


Type YES to perform the uboot.img flashing.

Since you already have the latest kernel installed, you need to reinstall it to update the extlinux.conf

sudo cp -r /boot ~
sudo rm -rf /boot/*
sudo apt-get install --reinstall linux-image-4.4.154-59-rockchip-g5e70f14

Check the /boot/extlinux/extlinux.conf content and if kernel images and dtbs directory are there.

ls /boot

The new extlinux.conf should be like this:

label kernel-4.4.154-59-rockchip-g5e70f14
    kernel /vmlinuz-4.4.154-59-rockchip-g5e70f14
    devicetreedir /dtbs/4.4.154-59-rockchip-g5e70f14
    append earlyprintk console=ttyFIQ0,1500000n8 rw init=/sbin/init root=PARTUUID=b921b045-1d rootwait rootfstype=ext4

Reboot. If everything works well after the reboot, you can safely remove ~/boot previous copied.

Worked flawlessly! Thank you!

Linux rock 4.4.154-59-rockchip-g5e70f14 #4 SMP Fri Dec 14 20:55:41 CST 2018 aarch64 aarch64 aarch64 GNU/Linux

It`s great to see the evolution in software. You are miles ahead on the competition on that. Keep it going like this.

Any idea when LibreElec and RecalBox will be released? Ive made a review video about recalbox some weeks ago. Im wondering when I can publish it.
Thank you.

1 Like

Hi Nico,

I had been meaning to ask you about when you would release your updated video but I guess this answers that question. Do you have a test image of LibreElec? I saw on Telegram that someone used a generic rk3399 LibreElec image and it was partially but not fully working. Would be interested if you tried something similar and did a video of what was and wasn’t working?

For reference, the version they tested was:

Ive tried Kodi in RecalBox. 4k video played well, but without sound. In Kodi sound didnt work, and bluetooth didnt work in emulationstation. My video is still unpublished, but you can see it here. Please let me know what you think. Im no gamer, so it`s a bit out of my comfort zone.(I hope I may share it, otherwise delete the link->mods)

Im also working on 4k video support in Linux with some people from Armbian.(and official Armbian research has started too, so it will soon be supported by them too) This for another video aboutvideo editing on SBCs. It could be very close to working. Ill let you all know when it works. Im also waiting for a new camera to arrive to be able to film more. My cheap camera can`t handle low light in the winter.

Does rockpi 4b Support VFPV3?

If yes how can i turn on this option? When i try to compile openCV with this option i get an error. ( -D ENABLE_VFPV3=ON )

I think this is the right topic to discuss about this but here is the answer:


An optional extension to the Arm, Thumb, and ThumbEE instruction sets in the Armv7-A and Armv7-R profiles. VFPv3 can be implemented with either 32 or 16 doubleword registers. VFPv3U is a variant of VFPv3 that supports the trapping of floating-point exceptions to support code.

ROCK Pi 4 is ARMV8, so no VFPv3. You can check

So NEON is supported, right ?


NEON is supported.

You can now try any version of the system with USB (without having to have a working u-boot for a specific version of the model). Alternatively, you can try the latest versions of Libreelec (official and non-official versions). :slight_smile: