Need root on Android radxa image

I need root, I’ve tried magisk but without success, how do I get it?

@floyd4ever don’t bother with rooting, use a well-made android image instead, which can be switched to rooted in setting.

Thanks !!! my board only has 2GB, is it compatible?

I wouldn’t try it, because there is one for the 2gb version:

Is that with 5GHz wifi? I remember that is the case, but if not then:

Sim ele tem wifi 5ghz, eu preciso para o que estou fazendo

This one then:

I will try and let you know

HI, did you compile this image? It works very well, but for me it lacked the usb accessory mode that is available in the image, I tried to put the xml file in /system/etc/permissions /android.hardware.usb.accessory.xml
but it didn’t work, maybe have to enable it during compilation.

What do you mean by usb accessory mode? I haven’t compiled anything, because it is a Russian made ROM by slimboxtv. All the usb is working as intended for me with this rom, except for my USB type C lan, but that is because it is not supported by this os version i think (another one is working with an OTG host usb).