My Rock Pi 4 no longer booting Android

Hey guys,

I’m having some trouble with one of my Rock Pi 4’s, it’s not booting Android and doesn’t have a HDMI signal… but I do get both the LED’s and a solid blue.

I initially thought it may have been an adapter issue, but I used an Anker QC 3.0 power adapter… and it doesn’t work. I have another Rock Pi 4, which can run Android just fine using the same power adapter.

I think I may have messed something up when I was trying to get a build of CentOS running on it… so I’m not sure how to fix it, or if this was the actual cause. But when I try Ubuntu Server or the Debian stretch image… it works fine. I’m using eMMC modules. If anyone can help shed some light, I’d appreciate it greatly. Thanks!

I just tried a SD card booting to Android, and it worked!

But anyone know what might have happened to the eMMC slot + Android for me? Cause I have no clue =(, thanks.

After tinkering around for a few hours, I’ve found the reason to be part of the SPI flash. After I connecting pins 25 and 26 together, put on the eMMC and then start up the Rock Pi… it worked in booting Android from eMMC.

I have did the SPI bootloader update while on Debian stretch, not sure if this may have anything to do with it.

After I get my USB A to USB A… I’ll look into the SPI thingy some more and report back. At the moment, I still can’t boot specifically Android or Android TV without connecting the 2 pins together.

1 Like