My board was died

After the reboot my board was died.
The only mmc and usb ssd has been connected.

After the board rebooting I faced with an issue then SoC is very hot. Now board blinks for 5 times and that is all ((

Radxa, what the hell?
I am owner of the tons SBC, some of them from the first revision. No one was died ((
Lack of software support, quality of product and engineering, huge price.

No, thanks, it’s not what am need.

I don’t recommend buy that shit.

I’m sorry for the unpleasant experience you have. Have you tried to attach a USB serial cable only then power up the board?

Sure. I have tried. But nothing happened. After the connection power line main chip get hot and no logs inside serial.

Just stay relaxed. It’s just technology, it just happens from time to time. No reason to be abusive here.


We will just send you another zero but can you do us a favor that send the unit back to us to analyze? We will provide a defect report for it. It helps us to improve the quality of the sbc.


SBCs failures just happens, try to google something like raspberry zero died and You will get tons of topics with broken boards, simply overheated or fried with power adapter or some extra accessories. And there were many boards with known issues, some were fixed in next revisions and for some there are repair kits. Let’s hope this will improve future boards.

Large kudos for radxa team for their willing to help and replace board :slight_smile:


Bro, only thing I can help to smooth you down is to tell ya I’ve got & kept the body of RaspberryPi of each version! RPI zero, RPI3B and RPI4B… They die for no reason too. For sure I did not do any abuse to them.

1 Like

I’m happy to see you back up your product offering a replacement. I have been recommending the radxa zero over the raspberry zero and I’m glad I have been .

1 Like

I’m owner of the 3 generation of Rpi, Atomic Pi, jetson nano. I don’t have an issue with that devices. Only with dead sd card.
It’s not obvious to me that devices can die. During working with them.

But I know, shit happened.

you are a lucky guy!
i have some boards… rpi3… rpi zero… rpi zero 2… odroid xu4… odroid c4… odroid n2… pine a64… khadas vim1… khadas vim2… odroid pi…
odroid pi suddently do not power on… get hot and smels to burn…
odroid n2 with 8 months of use, rebooted and lost the 5v at the board… it’s a common failure of this board. i have to repair by my own 5v regulator have burn and replaced
khadas vim2 do not power on… checked, have burn the 3.3v regulator…

1 Like