MXQ-4K flashed brick

I quote:

You can always flash the rock, it never bricks unless some hardware damage occurs.

My MXQ-4K was looks fine, until I was tried to upgrade. I have Fedora Linux, and I like Linux. With RkFlashKit I was recognize the rk-3228 chip on MXQ-4K board, and several times flashed firmware by partitions via RkFlashKit - unsuccessful. Then,

./upgrade_tool uf /opt/update_7.1.2_rk3328_public_8189etv_20170616.img
Loading firmware…
Support Type:RK322H FW Ver:7.1.00 FW Time:2017-06-16 19:13:43
Loader ver:2.39 Loader Time:2017-03-31 20:47:59

  • said -
    Check Chip Fail

Hm-m? I tried
./upgrade_tool uf /opt/update-rk3229_5.1-mxq_4k-ota_v0-20160516.img
Loading firmware…
Support Type:RK322A FW Ver:5.0.00 FW Time:2016-05-16 20:00:58
Loader ver:2.31 Loader Time:2016-05-16 17:47:09
Wait For Loader Fail - and at this point I got the brick.

The board doesn’t recognized in lsusb list with factory reset pressed, the red led on board is lighted.

I think you need to go into maskrom mode

Right said! Got it, connected 7-8 pins and voi la -
lsusb
Bus 001 Device 064: ID 2207:320b - live!

However - stopped on
./upgrade_tool uf /opt/update_7.1.2_rk3328_public_8189etv_20170616.img
tool said -
Loader ver:2.39 Loader Time:2017-03-31 20:47:59
Download Boot Start
and waiting…

I think I need run:

upgrade_tool db out/u-boot/rk3328_loader_ddr786_v1.06.243.bin
upgrade_tool wl 0x0 out/system.img
upgrade_tool rd # reset device to boot

When I try
./upgrade_tool db rk3328_loader_ddr786_v1.06.243.bin
got
Open loader failed,exit download boot!

Rockusb>UL rk3328_loader_ddr786_v1.06.243.bin
Loading loader…
Loading loader failed!
Rockusb>UL rk3328_miniloader_v2.43.bin
Loading loader…
Loading loader failed!
Rockusb>UL /opt/img_MXQ-4K_ota/loader.img
Loading loader…
Loading loader failed!
Rockusb>UL /opt/rk3228/img/loader.img
Loading loader…
Loading loader failed!

Linux_Upgrade_Tool_v1.21]# ./upgrade_tool
List of rockusb connected
DevNo=1 Vid=0x2207,Pid=0x320b,LocationID=141 Maskrom
Found 1 rockusb,Select input DevNo,Rescan press ,Quit press :1

Rockusb>RS 0x00002000 0x00004000
Error:Read sector failed!
Rockusb>TD
Test Device Fail!
Rockusb>

Rockusb>UL /opt/img_rk3229/update/RK322XMiniLoaderAll_V2.31.bin
Loading loader…
Support Type:RK322A Loader ver:2.32 Loader Time:2017-05-18 16:12:59
Upgrade loader ok.
Rockusb>TD
Test Device OK.
Rockusb>RID
Flash ID:AD DE 14 AB 42
Rockusb>RFI
Flash Info:
Manufacturer: HYNIX,value=02
Flash Size: 8448MB
Block Size: 4096KB
Page Size: 16KB
ECC Bits: 40
Access Time: 32
Flash CS: Flash<0>
Rockusb>RCI
Chip Info: 41 32 32 33 0 0 0 0 0 0 0 0 0 0 0 0

You have a rk322x device probably still with nand storage, so don’t flash rk3328 firmwares or bootloaders since that will brick your device.

mo123, already bricked once! :slight_smile:
Now try to load firmware,

Rockusb>UF /opt/MXQ_4k_1GB_8GB_Andr_5.1_Superceleron_v1.0.img
Loading firmware…
Support Type:RK322A FW Ver:5.0.00 FW Time:2016-07-30 03:12:54
Loader ver:2.31 Loader Time:2016-06-22 21:15:53
Wait For Loader Start… and -
Wait For Loader Fail

I have restored with command
./upgrade_tool uf /opt/mxq-4k_1G8G_rtl8189_20171113_r1.img
However, the screen is showing only MXQ-4K logo :frowning:

RkFlashkit show more - looks like itsa rk3228 nor rk322x device!

Reading flash information
Loading partition information
MACHINE_MODEL:rk3228
MACHINE_ID:007
MANUFACTURER:RK30SDK
MAGIC: 0x5041524B
ATAG: 0x60000800
MACHINE: 3228
CHECK_MASK: 0x80
KERNEL_IMG: 0x60408000
#RECOVER_KEY: 1,1,0,20,0
#CMDLINE:console=ttyFIQ0 androidboot.selinux=permissive androidboot.hardware=rk30board androidboot.console=ttyFIQ0 init=/init mtdparts=rk29xxnand:0x00002000@0x00002000(uboot),0x00004000@0x00004000(trust),0x00002000@0x00008000(misc),0x00000800@0x0000A000(baseparamer),0x00007800@0x0000A800(resource),0x00006000@0x00012000(kernel),0x00006000@0x00018000(boot),0x00010000@0x0001E000(recovery),0x00020000@0x0002E000(backup),0x00040000@0x0004E000(cache),0x00008000@0x0008E000(metadata),0x00002000@0x00096000(kpanic),0x00400000@0x00098000(system),-@0x00498000(userdata)
CMDLINE:console=ttyFIQ0 androidboot.selinux=permissive androidboot.hardware=rk30board androidboot.console=ttyFIQ0 init=/init mtdparts=rk29xxnand:0x00002000@0x00002000(uboot),0x00004000@0x00004000(trust),0x00002000@0x00008000(misc),0x00000800@0x0000A000(baseparamer),0x00007800@0x0000A800(resource),0x00008000@0x00012000(kernel),0x00010000@0x0001A000(boot),0x00010000@0x0002A000(recovery),0x00020000@0x0003A000(backup),0x00040000@0x0005A000(cache),0x00008000@0x0009A000(metadata),0x00002000@0x000A2000(kpanic),0x00400000@0x000A4000(system),-@0x004A4000(userdata)

Partitions:
uboot        (0x00002000 @ 0x00002000)    4 MiB
trust        (0x00004000 @ 0x00004000)    8 MiB
misc         (0x00002000 @ 0x00008000)    4 MiB
baseparamer  (0x00000800 @ 0x0000A000)    1 MiB
resource     (0x00007800 @ 0x0000A800)   15 MiB
kernel       (0x00008000 @ 0x00012000)   16 MiB
boot         (0x00010000 @ 0x0001A000)   32 MiB
recovery     (0x00010000 @ 0x0002A000)   32 MiB
backup       (0x00020000 @ 0x0003A000)   64 MiB
cache        (0x00040000 @ 0x0005A000)  128 MiB
metadata     (0x00008000 @ 0x0009A000)   16 MiB
kpanic       (0x00002000 @ 0x000A2000)    4 MiB
system       (0x00400000 @ 0x000A4000) 2048 MiB
userdata     (0x00BDC000 @ 0x004A4000) 6072 MiB
Done!