Mali hardware accelerated video player?

So both mplayer and VLC are playing very badly and I was wondering if someone could please show me a video player that can use the MALI hardware acceleration?

It is best to use the arm64 Ubuntu Server for that.
Install a desktop on it. With Firefox you can watch video’s with HW ACC.
VLC works without stuttering, but lesser frames.
Also for Youtube playback Firefox is perfect on arm64. No dropped frames in 1080p.

Greetings, NicoD

Edit : Firefox is no good for surfing tho, for that I use Vivaldi browser.

On armhf Chromium didn’t work with me and also Firefox. Vivaldi again worked great there. Is Chromium also not working with you? I know firefox doesn’t work on a armhf system.


Here is how to install a desktop on Ubuntu Server.

Ubuntu Server

Ethernet doesn’t seem to work
Connect wifi : No /etc/network/interfaces file
instead do -> sudo nmcli dev wifi connect ESSID_NAME password ESSID_PASSWORD
Wifi shuts down while downloading a desktop -> reboot and restart the installation

install desktop -> sudo apt install lxde (for only lxde)
sudo apt install ubuntu-mate-core && sudo apt install ubuntu-mate-desktop (for the Ubuntu mate desktop)
sudo apt install lubuntu (for Lubuntu desktop + LXDE desktop)

If possible, could you check if your ethernet works on Ubuntu Server without a desktop installed? Please let me know.

I’m bussy researching the RockPi 4B for a review. It would save me some time if you could confirm these things.
No problem if you can’t, greetings.

1 Like

I just tried armhf Debian and MPV player seems to work fine here.
It’s with a 1080p 30fps video that I tested it.

Yeah sorry for providing poor information about my issue and thanks for helping. :relaxed:

I am in need of streaming a TS 1080i file from my Vu+ satellite, linux based decoder for a MagicMirror project.

It was running fine and smooth on a poor Raspberry Pi 3 B+ by using either omxplayer or VLC, but it is not on the powerfull Rock Pi 4B.

Do you still think that moving to Ubuntu Server would do the trick? :thinking:

Here are the example informations of a 1080i stream (taken from the Windows 10 version):

Also @NicoD if you live in Europe and are in need of the Rock Pi 4 you can already buy it at or at . :wink:

Arm64 Ubuntu does have a lot of pros against armhf. Ive tried SMPlayer on it and it works great. You have to change some settings to work.
SMPlayer -> Options -> preferences -> video -> Output Driver -> choose X11
Maybe these settings also work on vlc in armhf.
I think you can stream with smplayer.
I`ll check tonight if it does.

I have a RockPi4B. It`s an awesome sbc.

I just tried in armhf Debian. SMPlayer works there too. Just : sudo apt install smplayer
Then this -> SMPlayer -> Options -> preferences -> video -> Output Driver -> choose X11

Also VLC works great with these settings.
VLC-> tools -> preferences -> Video -> Output -> x11 video output

I do prefer to work with a 64-bit OS on a 64-bit sbc. 32-bit OS’es have older repo’s. And most 64-bit programs are a lot better than their 32-bit counterparts.

I hope it helped you. Greetings, NicoD

Thanks will definitely try that as Ubuntu with command line only is definitely too hard for me. :sweat_smile:

1 Like

does MPV work for you?

I didn’t try it yet because I actually just found a post in another Rockchip users forum suggesting to use gst-launch-1.0 and I am testing it right now.

Looks like it is the most perfoming Mali GPU hardware accelerated video player at the moment. :grin:

For modern ARM SoC, the GPU is not for the hardware decoding task. There is dedicated hardware block to actual decode the media files called VPU. The recent Intel chip has that too. The VPU is more efficient than the GPU doing the decoding job. The GPU is mostly for 3D or 2D display acceleration, there is another block in Rockchip SoC called RGA for 2D acceleration.

Check the graphic diagram on Rockchip wiki.

For ffmepg, Rockchip has implemented a plugin to use the VPU. You can use

gst-launch-1.0 uridecodebin uri=file:///usr/local/test.mp4  ! rkximagesink

To test it.


I actually tested it with the stream I mentioned before and I have to say that it is working very good!
Perfect sync and no stuttering.

So far my issue seems solved thanks! :+1:t3:

1 Like

Any chance I can setup the window size somehow?

Couldn’t find results on Google so far.
What do you mean by setup?

Sorry I meant ‘set’. :slight_smile:

I would like to set height, width and window position.

gst-play-1.0 that was mentioned in first post of thread i linked will do

1 Like

It’s strange. Firefox works without hardware acceleration for me. Tried along with xubuntu-desktop and mate.

In case you use Debian Desktop - you need to activate it first i believe. More on it there

In case you use Ubuntu Server that was unminimized to desktop - you need to build rockchip’s Xorg to be able to use hardware acceleration