Madgrizzle's Robot Sample Support Thread

I’m making this post as a blatant attempt to get a sample Rock Pi X… not going to try to hide that. I put a poll at the bottom that you can show your support if you are inclined.

I’m going through a mid-life crisis and decided to accomplish a childhood dream of building a robot. I was first inspired by this book as a kid but never really had the means to acquire the parts… back in the 70’s, you couldn’t just google things.

My first attempt was based upon repurposed motors from spare parts of four-motor CNC machine design I worked on but abandoned. My robot was crude to say the least. Note the handmade wheels:

Besides being very wobbly (not a structurally sound design), the wheels slipped quite a bit. It did move though, but to get it to move accurately wasn’t going to happen.

So I built version 2, this time using PVC pipes as structural members. It worked much better but the mapping with the kinect just wasn’t working well and I invested in a ROS-support laser scanner with built-in mapping. I discovered upon receiving it that the software only ran on an x86. I had a N3150 (quad celeron) unused so I rigged it up and began using it… here’s version 2:

image

This worked much better, but because I had to use large wheels (the repurposed motors turn at 20 rpm, so I need large wheels to counter the slow RPM), the base was very wide and I couldn’t navigate through doorways well. I tried adding sonar sensors, but kept getting frustrated with working on the robot because to do anything I had to basically disassemble the whole thing. The axles were supported by bearings seated in plywood supports, but they didn’t really turn well. I also ran out of battery quickly and thought I’d use an atom-based PC instead of the N3150. With all of that in mind, I decided to build version 3 using 3D-printed parts along with flat plywood parts. I waited for the Rock Pi X to come out, but when I was ready to move forward, I had to grab an atomic pi instead.

Here’s version 3 without all the electronics added. Each level can rotate around so I don’t have to disassemble to access something.

And, how it is with the electronics (the kinect will move to near the top of the PVC pipe)

This is where I stand today… the atomic pi has a fatal flaw in that the single usb-port does not have enough bandwidth to support a Kinect and ANYTHING else. The Kinect uses all the bandwidth somehow. There is another USB port, but its not a standard cable layout and I’d have to solder something up to use it. It’s also only 2 GB of RAM.

So, my plan is to use a 4 GB Rock Pi X in place of the atomic pi. But they aren’t shipping quite yet, hence my unabashed plea for a sample.

Here’s a poll if you want to show your support :slight_smile:

  • I support this project receiving a sample
  • I support this project getting a sample
  • I support providing a sample for this project.

0 voters

8 Likes

Dear Madgrizzle_Maslow

I am impressed by your candid and sincere and thank you for your sharing.

We will definitely send you a ROCK Pi X for your robot.

ps: I am experiencing a mid-life crisis too but I think as long as you keep a positive mood, you can always overcome the difficulty.

Awesome! Thank you very much! Being able to keep all the functions on a single computer is really important from a power consumption standpoint and I think the Rock Pi X will work really well. I’ll send you my contact info in a PM. And as a small return of the favor, I’ll have my wife cut out a vinyl stencil of your logo and affix it to the robot (kinda like a sponsorship thing)

Again, thanks!

I got my sample today! Man, is that thing tiny! I plugged it in and was surprised it had Windows 10 installed on it. I went ahead and let it run through the installation and when done, I shut it down and noticed the processor was rather hot. I went ahead and popped off the eMMC and plugged in the second one that came with the sample and it appeared “blank”. Followed directions and got Ubuntu 18.05 server loaded on, and only had I slight issue. First time I went through the install, it failed to load the network drivers for the Ethernet. When I rebooted and tried again, it worked with no problem. :man_shrugging: ROS installed with little problem. Now working on transferring files from old computer to the RockPiX. I’m not really taxing the CPU at the moment and it doesn’t seem hot at all, but I had a spare heatsink from a RPI4 and went ahead and installed it. Not sure it will need it, but will find out when it starts running the robot and all cores at pegged at 100% utilization.