M.2 ssd is not recognized

This looks more familiar. Problem with the board? :confused:

Cant say if its a problem with the board or with u-boot unable to set up the SSD while booting.
If I find anything relevant will post here.

I got this error with one of my nvme drives (Silicon Power 512GB p34a80) on the current Armbian buster with kernel 5.4. However it worked fine on the latest Manjaro.

Hey @Druid
Where did you buy your Acer and it is working? I’m going to return the HP and try another one before thinking of returning the board (and probably go for something entirely different)…

Which one is more likely to work and boot SPI/SSD only?

  • Intel 760p Series SSD 128GB TLC PCIe NVMe 3.0 x4 - M.2 2280
  • Gigabyte NVMe SSD 128 GB NVMe 1.3 M.2 2280

Maybe some comments before I order?


The acer one is known working under u-boot:


@krang If you are from EU I bought it here.

Thanks, the two of you!
And @Druid, can you please let me know if it works? So excited. :slight_smile:

@krang Some delays with delivery. I only get it next week. I’ll let you know if Acer SSD works.

I have an intermitent issue with -110 on mainline 5.6.7, very strange. I have the HP EX900 above.

If I use the Rock Pi 4 Ubuntu 18.04 image then it works fine everytime.

1 Like

Funny, I didn’t get it to work with the same SSD and Ubuntu 18, amongst others.
Waiting for my Gigabyte SSD now, will order Acer if this fails as well…

Acer SSD is recognized. I was able to write image and boot from SSD only when SD is present. So it boots in a strange way.
Can anyone advise how to fix it (if it is possible).
In the logs I see

Scanning nvme 0:4…
Found /extlinux/extlinux.conf

But later I get

** Unable to read file /dtbs/4.4.154-59-rockchip-g5e70f14/rockchip/rk3399-rock-pi-4b.dtb **

Then it goes to sdcard and loads this

reading /dtbs/4.4.154-108-rockchip-ge9277b7e857a/rockchip/rk3399-rock-pi-4b.dtb

So it boots and when I check /boot directory I see that it is from SSD drive. And I don’t see rk3399-rock-pi-4b.dtb there I can only find rock-pi-4b.dtb.

There was another name for the file with this kernel (rockpi-4b-linux.dtb) . The programmers in the latest version of Uboot set a different file name rk3399-rock-pi-4b.dtb and therefore new versions of Uboot do not work with old kernels from radxa. Therefore, you must either apply the old uboot, or copy boot 4.4.154-108 from microsd instead of 4.4.154-59 … or copy all rockpi-4b-linux.dtb to rk3399-rock-pi-4b.dtb.

1 Like

can confirm it works with the Gigabyte SSD as well, at least the OS recognizing it with correct size.
I’m currently on the write SPI step and will decide to try Armbian or Debian on the SSD. Let’s see

can’t confirm, I don’t have such a device
I reacted to the case when a new Uboot does not load old images.

To @radxa: the link from the official site still has an image of ubuntu without the correct dtb file names. Probably it was necessary to first lay out the correct images of the OS, and then already make changes to Uboot?

Thanks a lot. It helped. I renamed dts file and it helped. Then I wrote an old u-boot (from apt bionic main) but it still reads wrong file. I guess I need to rollback to really old version which I don’t want. I think I need to create a ticket somewhere for radxa team.

He meant that he tried and Gigabyte worked for him.

I wrote copy, not rename. Then it will work with both the new and the old ones. Here’s how radxa does it in its latest kernels

# ls /media/BOOTMATE/dtbs/4.4.154-105-rockchip-ge14b7341757f/rockchip/ | grep rock.*pi.*4.*

boot armbian from SPI+NVME only also works smoothly on the gigabyte as stated.
I basically booted the latest official debian desktop from radxa download, upgraded it to the latest version using apt upgrade which also updates SPI. then I just unzipped/flashed the latest armbian buster desktop (will switch off x once initial config is done) and it worked.

thx for community help, nice little group, happy to participate.

1 Like