M.2 is not recognized Ubuntu 18


#1

The Rock Pi 4B is not recognizing my drive ( Mushkin Pilot 120GB M.2 nvme ). What is the likely reason for this?

Do I need to install a driver?


#2

Was it initialized before? I.e. does it have filesystem?


#3

As far as the “Mushkin” devices. I tried both, initialized and uninitialized. The initialized drive was partitioned as an ext4 ( built on ubuntu 18 from a separate machine ). Neither of these showed up as a device.

I also tried a: “128GB PCIE M.2_2280 Patriot Scorch” which did work ( uninitialized ) and seems to be performing well. It showed up as /dev/nvme0n1 and I’m getting about ~450MB. I’m happy with that.

but, I’d like to know what the difference is. Why did the Mushkin devices not show up?


#4

fdisk -a don’t have this too? What about lspci?

Sadly Google said nothing


#5

I tried a Adata XPG SX6000 Pro on Ubuntu 18.04.1 LTS:

Linux linux 4.4.154-59-rockchip-g5e70f14 #4 SMP Fri Dec 14 20:55:41 CST 2018 aarch64 aarch64 aarch64 GNU/Linux

When I try any command == no response … even reboot :thinking:


#6

I’m not sure if it has anything to do with it, but the M.2 that worked had both M & B Keys.