Issues with NVMe boot

Yesterday I received my rock 5, now trying to set up a boot from the ssd.

Faced the following problem: at startup, the board is in an endless reboot. The bootloader from the wiki loaded without errors, Ubuntu image from the same wiki - too (there was a warning from parted that the gpt table does not use the entire volume of the ssd).

Once I was able to catch an error running across the screen in the photo

Ssd: samsung 970 evo plus

read errors appear when i plug in usb keyboard (and also when pull it out)

also tried Debian image, same issue, infinite reboot

When i tried different ssd (lite-on), board successfully booted into Ubuntu. When I executed sudo apt update && sudo apt upgrade -y, everything was ok, then I just rebooted the board and it is broken again. The same infinite reboot

Btw if i just use sd card, everything is OK. This issue occurs only with booting from ssd. But I don’t want to use sd card

I thought that this may be PD issue, but the behavior is inconsistent. Once it is just in an endless reboot, the second time it stops and displays an error message, the third time it loads, updates, and does not load after the update, and so on

In a few days my new Anker A2148 will arrive, which, according to the wiki, is stable. Will try with it and armbian too. But I really want to just use official Ubuntu image with nvme samsung ssd, setup k3s cluster and don’t waste my time on OS/boot issues

  1. It’s out of stock
  2. I already wrote that a power supply is coming to me, which is guaranteed to work with the board, according to the wiki. Why buy another one?
  3. I already wrote that it sometimes booted with the current power supply. If the problem was in it, then it would probably crash all the time? I decided to check the power supply just in case

ok, problem solved.

I just decided to try the power supply from my old phone (POCO X3 Pro) and everything worked fine with it. Apparently it was all about PD.

So, as a result:

  1. Anker A2046 doesn’t work (infinite reboot)
  2. Stock power supply from POCO X3 Pro works fine

Thought I’d share my experience with this drive. I upgraded to the 2TB variant and was initially pleased. However, there were intermittent stability issues resulting in hard crashes. After one such crash, my rock5b refused to boot, not boot looping, but stuck in the bootloader with a solid blue LED. The data on the drive was error free and the drive worked fine in another machine. I wound up switching back to my original, cheap drive, a PNY CS2130, which remains stable. I have access to a couple 60w supplies and a 120w, all of which work well with most accessory combinations I’ve tried. My primary power sources are from RavPower.

Note, I did wipe the boot partition on the EVO to see if my rock5b would boot to SD, but it subsequently refused to boot with the EVO attached. So, I don’t suspect data-related issues.

Since, I’ve upgraded to a 2TB SK Hynix P31 Gold. While I’ve only been testing for short while, it looks to be stable.

In summary, well working NVME drives so far:

  • PNY CS2130 1TB
  • SK Hynix P31 Gold 2TB

I’d be curious to hear if your 970 EVO Plus remains stable after more usage.

Everything is stable at the moment. I have a 500GB variant, a k3s cluster is constantly running on the board, in which two dozen applications are deployed (that is, the ssd is accessed, because the database is also there). There were no problems

Are you sure you had enough cooling for the samsung ssd? They are one of the fastest and most reliable, and therefore the hottest. Without a heatsink, or with a weak heatsink, they easily overheat and start producing reading errors. I have a special heatsink for ssd, 2cm thickness, glued to it with a thermal pad)

I do have a low profile heatsink and temps were not near the critical threshold. I suspect my issues may have been related to the many firmware-related issues consumers have been having with the high capacity variants of the 9xx series. I’ve had some trouble confirming the controller, but lspci shows Samsung PM981 which I’m assuming uses the Elpis controller. The behavior of the drive matches the many consumer complaints I’ve seen scattered across the web.

The good news is that the SK Hynix P31 has been rock solid and performs well. Would recommend.

Just wanted to reply to caution other users against Samsung 9xx drives >500GB, as the controller switcheroo in the past year or two has led to many premature failures and stability issues.

I’ve been struggling with the exact same issue with the 970 Plus.

Do you know what FW version you were running on it?

Mine is running: 4B2QEXM7

It’s the most recent according to Samsung, but I’ll be updating as soon as I can. Though, this drive now lives in my desktop, where it has been stable, so far.

crap, i was hoping the latest fw update would fix the issue.

the alternate nvme you mention i can’t source where i’m at.

any idea whether the WD Black SN750 plays nice with the rock5?

It does as long as you use Radxa official 30W PSU. SN550, SN750, SN850 and my favorite WD black SN770 worked just fine for me. I did have some stability/reboot issues when using uSD card and NVMe simultaneously with 65W and 45W USB-C PSU from allnetchina but once I switched to RADXA Power PD 30W PSU everything worked as intended.