Is there an image with LUKS encryption + open media vault

Hi all,

does anyone know an image for the rock pi 4 that is debian + omv + luks?
I can only find variants where at least omv or luks (dm_crypt module) are missing.

You prob would have to follow the build script https://github.com/radxa/rockchip-bsp
amend defconfig with dm_crypt module
then just install OMV on top

I am waiting for delivery of a 4 port sata m.2 and a new rockpi4 as was going to try that myself, when they arrive.
You will have to check as it might be like g-ether where its enabled as a module but the module is not compiled and needs to be added.

Cool, thank you. i will try that out the next days. Hope it works.

Has all the Device mapper configs set to manual Y would set them to built in.
I guess somewhere in the rootfs you declare to compile the modules

Base rather than Desktop builds the headless server version using Part 2 of the https://github.com/radxa/rockchip-bsp

Buster is released on July 6th and that is also what I am waiting for with 5.2 but might see how I go with 4.4 & stretch.

Just checked that the Pi4b2g might turn up today so will share an image that I have started with this weekend.

I am going to be using a Marvell 9235 4 port and also waiting for that.

Not sure if I am going to use OMV as also looking at https://github.com/davestephens/ansible-nas

You can have a go with this image.
OMV Arm64 Image
https://1drv.ms/u/s!AocmAh35i26QiRoVLn1ttnlorw8g
Debian user:password rock:rock
OMV user:password admin:openmediavault

The dm_crypt is a module so just modprobe dm_crypt

ps forgot to re-enable the resize helper for /
sudo systemctl enable resize-helper.service reboot

2 Likes

cool thanks a lot for this service

Its just the debian build service using target=base arch=arm64 with the radxa repo’s and packages.
Plus OMV ontop of that with no customisation so essentially its the radxa image with just a bit of work for OMV already done.

https://wiki.radxa.com/Rockpi4/dev/Debian

Just forgot to enable sudo systemctl enable resize-helper.service so it runs on first boot and disables itself again.
If there are any module needs or probs post as aiming at an OMV install myself so will run through again if anything is missing.

Hi just, tried to boot from the image but the device was not coming up in my routers nework client list. … will give it another try later on sometime

It is here just check, do an ip a and check the ip and mac and see if that is connected on your router.
Hostname is rockpi4 and check that you don’t have old ghosts still in lease with the same name as sometimes happens.

Dunno if I have ever checked the WiFi but ethernet never had a problem with.

router

mh, idk what is the issue. my rpi gets detected smotth, the image (copied with etcher) does not show up on the network. whatever, i thank you very much vor your help.

have you logged in and done an ip a to see the ip and mac address?

i cant login in. even if i plug a screen nothing happens. i also used all i can nmap, router tables… maybe its doing the rezising for quite some long time …

Looks like the image hasn’t worked, nope ist quick and resize is missing .


It does.as just used it to test a RAID setup. For what ever reason I will hazard a guess that image is not loading.
I would try the basics like burning the image again making sure SD card is in correct and right way round and that its loading.
Takes 20-30 secs to load to login and you should see the Red activity led flash as it does.

@stuartiannaylor, thanks for your help. i made it working now! Cloned the armbian repo --> build with docker (the config menue is awesome) selected there the config for dm_crypt --> build image --> replaced my old pi. The rockspi is a beast in performance, really fun to use it.

It is I am raving about OMV now as I have always dodged it in the past because “Yeah its just Nas”.

With the DNS/DHCP, fail2ban, samba, iptables and then docker its this very efficient home/soho server base.
I have a 4 port sata card running x4 cheap 120gb SSD in a RAID10 there is a 5port that I missed that maybe could do RAID6.

I have set the docker root to the raid partition and been running nextcloud in it but failing mightily to compile LibreOfficeOnline for Arm64, but hey.

In a home environ I have been sort of thinking of the “Magic Mirror Server” that is actually quite heavily loaded with things like OpenHab, NextCloud, MagicMirror, Alexa and also connects via USB3.0 to a jbod media store of USB3.0 attached disks.

The 5.1-20V input has me using 12v ‘cctc’ 5.5mm barrell PSU of 60watt that range up to 100watt in that laptop format, which also great as its so much easier to power peripherals.
Yeah I am having great fun and ‘How’ capable I have found the RK3399 to my other preference of recycled old Intel has actually surprised me.

OMV has been a great find as it has just enough on the host and then everything else can be isolated via docker at the network level so its actually becomes extremely simple to run complex systems.
Maybe in 5.0 they are going to continue in that vein and stick to a bare minimum of networking and disks on host and everything else containerised. I will be having a look at the next Buster version for sure.

The Snapraid / UnionFS also another thing new for me but for the purpose of a large file media store on a jbod of usb3.0 disks its a perfect fit for the economies and use of home.
Yeah its just a scheduled parity backup but for simplicity and ease of use it is perfect for home use and its another I have seen for a long time and never used.

Home / SoHo curren’tly the RockPi4 far exceeds any previous ARM platform I have used but surprisingly its giving the recycled option a good run for like money and probably clearly surpassing due to power draw without loss of needed process power.