Is there a problem with the Rock Pi4B's analog?

I have now tried Armbian and Xubuntu on my new Rock Pi4B. The audio device in the RK3399 is found by aplay -L but the audio jack is completely dead. No audio in or out of this device. Is there a problem with the Rock Pi board that hasn’t been addressed yet or do I just have a defective board?

I installed the Official Debian OS for the Rock and the audio out of the RK3399 now works. Unfortunately, my Input audio is still dead. It now looks like I received a defective Rock Pi4B. I will be asking AllNet for a replacement.

Your observations actually point to a NOT-defective unit.
If a software change can make the audio behavior change, then the hardware is fine.

It is very possible that the audio IN is simply not tested by anyone, so if a bug creeps up in it (or it never worked to begin with), it is unlikely that anyone would notice.

Try with Android (tablet version, not TV version), as it is more likely to have attention paid to media capabilities than GNU is.

Hi ThomasJ,-
the board is not defectiv, but: the Mic-In seems not to be connected intern to MiceBias. And so the input Voltage has to be about 3V for full Input. May be the intern MiceBias connection has to be swiched on/off via driver. That is a question to the RADXA-team! I could not measure any BIAS-voltage at the input pin of the audio-jack. You can use a little USB- Soundcard wich works OK! Good luck-Boosseiner!

So presumably, you have been successful at receiving LINE LEVEL input?

The schematics show microphone bias to be connected, however, the schematic is a little unclear around it; page 26.

Especially note how the microphone connection is shown as connected to the jack.
Pay close attention around the differences in the nokia vs standard wiring scheme;

The schematics appear to indicate STANDARD wiring.

And as far as the driver goes, it DEFINITELY needs to be set correctly for the microphone bias to be activated.

Refer to alsamixer or tinymix to set the conditions for this.