Install operating system on Rock Pi x

I am trying to load an operating system on the Rock Pi X. I formatted the emmc and tried both fat32 and ntfs on the usb drives on both of them… I loaded the Radxa recommended systems using Etcher on a usb3 flash drive and used the bios settings in "boot over ride "section to choose the usb3 drive to boot to. The system then goes blank with no activity. I even waited about 40 minutes to see if anything happens but nothing. I tried several distros to no avail using both the fat32 and ntfs formats. I tried the same thing with Win 10 (from Microsoft dl) using Rufus–same thing. I also flashed Win10 directly to the emmc like it was when I got it. When it ran it was like molasses—slow. Now nothing. I have always used etcher or Raspberry Imager for all my Rock Pi’s and Raspberries with no problems. Having Windows on this x86 board would be nice but I don’t think it will run it. My other Rock Pi’s run great. This was given to me as a test subject for new and unusual cases. I would sure love to use it. Any ideas on what I’m missing? It is probably something simple!

Please reformat your message a bit. This wall doesn’t really help with understanding what kind of problem you have.

  1. You formatted emmc with pre-installed Windows 10 (?)
  2. You tried to install some OS (which one?) on RockPiX
  3. You tried Microsoft msdn version of Windows 10
  4. You flashed iso file on emmc with windows 10 (???)

Maybe you have met this kind of problem