Install Manjaro into eMMC

Hi, I am trying to installation of Manjaro ARM to eMMC storage. To achive this I created Ubuntu uSD card and booted with this. I downloaded manjaro image from Github and extracted *.img file on Ubuntu uSD. Flashed internal eMMC with “sudo dd if=./Manjaro-ARM.img of=/dev/mmcblk0 bs=1M” and powered off (systemctl poweroff) Radxa Zero. Then unpluged radxa and removed uSD. After that I supplied power and RZ not booted. I checked partitions with “sudo fdisk -l” command and eMMC has two partition but none of them flaged as bootable. I flaged manually and there is no change. With same method I succesfully make bootable Ubuntu on eMMC. I am insisting on Manjaro because its more recent and better GUI than Debian (Ubuntu do not have desktop environment).
Anyone can help me? Thanks.

That is correct, but operating system is a lot more than that. What about facts that you don’t want to see? Do you think your problems will be over once you find a way to get OS on eMMC?

I also tried to flash Manjaro from GitHub with no success. @Janik seems to have a working one. Mind sharing some secrets?

Hi, My objective is installing one of popular arch linux distrubution in here. I am not discussing which distro is best or worst. I tried debian and added more recent repos. At the end of day, xfce and debian has issues such as wi-fi connection not a user friendly and RZero works at higher temp (sensible difference). When these problems solved, I can migrate to Debian.

I installed my Manjaro on the SD card not on the eMMC. But there I had no issue.

I will check the images and update whats needed for it to work on emmc.

Its not very start forward with amlogic soc though.

We can have mainline uboot images to be used so it can be used with sd and emmc when emmc is blank.

I have updated boot-radxa-zero package which is responsible for booting the linux kernel.
Now it uses bootscript instead chainloader.

Advantages bootscript:

  1. Boot from SDcard and usb.
  2. Install image to emmc using the script.

Disadvantage of bootscript:

  1. Can only boot with Vendor uboot on emmc.

After updating the boot-radxa-zero pkg please re-install the linux kernel before rebooting otherwise the system will not be able to boot into linux.

sudo pacman -S boot-radxa-zero linux-rc

sudo reboot now

BTW radxa-zero images are not flashable on emmc directly cause of amlogic bootloader.

I’ve tried to make an updated guide on how to do this for the Zero emmc process. There is a step to get uboot onto the emmc for it to work:

Let me know if that was helpful at all. Currently, I just realized that the onboard wifi does not work or is not detected by the OS.

Ummm I just flashed Manjaro-ARM-minimal-radxa-zero-20211208.img.xz to eMMC and got serial console and HDMI output. U-Boot version is 2015.01-g2a379c9 (Oct 20 2021 - 06:40:24).

Thank you for attention, but I’m relatively new in this world. Where can I found script? I also wondering, how ubuntu/debian distros can boot? Thanks.

I will try it when I turn back to home. Thanks for attention.

It is inside boot directory.

Hi, I tried new image by flashing Etcher with Windows tool not successful.
I booted Ubuntu Server on Radxa Zero via uSD card (empty eMMC module) and tried to flash eMMC. However I cant boot. While I’m on Ubuntu server, mounted boot partition and run and there no change. As a result I failed on my all attempts. Thanks.

The Manjaro image uses bootscript which uses Vendor uboot which is used in Android on emmc.

If you have any other uboot on emmc then things will not work as expected.

In that case vendor U-Boot can be installed after the fact with methods mentioned in Wiki right? Working on some Armbian stuff so I can’t test it myself at the moment.

I had trouble with the 1208 version. Go one release back (1206) and it worked for me

I got same result. I think I caused something broke. Sorry for this.

I tried running the install-emmc-script on radxa zero and I am getting mmc timeout errors and IO errors.

I feel there is some issue with mmc driver for zero.

I have flashed manjaro kde, xfce, and gnome successfully following the guide at the middle of this post: Updating instructions for reflashing and booting off EMMC?

I used this release found on github:

also…I unarchived the .xz so that the image was uncompressed (.img vs .img.xz). I’ve had issues in the past when trying to flash a compressed image to disk.

(there is a new image for 1213 just released but I’ve had no issues with the 1206 version…and since it’s manjaro, you can just pacman -Syu to update the system to latest anyway…)

Can anyone follow the instructions and let me know if it works for you? If you are on windows, using the default guide with the gui programs that radxa mentions and Etcher is fine; just confirm after you’re done if there is a boot and root partitions are created. Then you’ll want to figure out how to get uboot.bin onto the drive… (which in Linux land, it’s by using dd if=uboot.bin of=/dev/<diskname> bs=512 seek=1)

The reason it doesn’t boot (in my experience) is because the image doesn’t have whatever uboot.bin adds to the boot partition or emmc disk.

Just tested with latest 21.12. No issue booting from eMMC, microSD or USB drive (for latter two eMMC is wiped with fastboot erase 0).

However other distros only boot from eMMC :frowning:

Please explain how you do it?
For my emmc i am having mmc timeout which is either a drive issue of a bad sector on emmc.