I can't pair a bluetooth device on android 9

I try to pair a bluetooth module, it finds it in the list of devices more when I put it to pair, the communication error. This only happens with the android tablet version, in the android TV version it finds and connects normally.

I need it to work on android 7 or 9 tablet mode in order to use my gamesir x1 module.

Anyone with this same problem? Can you help?

Can you take a logcat on Android tablet 9 OS after receiving the error?
Perhaps also a screenshot of the error.
Also get a logcat on AndroidTV 9 where it is connecting correctly.
What is the other problem of AndroidTV not working with the device?
Is there any app you also need to use with the device or not?
If you use certain apps, you can change the UI Mode of the app to TV, normal, Car etc. in the apps settings, maybe changing it to normal instead of tv will help ti make it work in tablet and not tv mode.

Then maybe Radxa can investigate next week if they see a problem.

On AndroidTV my device connects normally, and the application that is used together with the device to map the keys and mouse on the screen does not work properly, so I need to use it on the Android Tablet! On Android Tablet my device is not connecting, the device is found in the list, but it does not connect. As soon as I have some time, I’ll take an SS of the error message!

I did some tests with other devices that I have here … In this case a Bluetooth headphone and the mi band 4.

The headphone connected normally …

My mi band 4, on the other hand, appeared on the list and when I put it to pair, I kept trying to connect but it didn’t finish.

On AndroidTV, you use a different settings app correct, the one that shows on the right side of the screen with a black background? Here things work better?

Maybe the problem is with the Settings app on the tablet firmware.
It might be possible to replace it with the TvSettings app used on AndroidTV that shows on the right side of the screen.

On AndroidTV I already tried to change the settings in the UI, among others … Plus the mapping app does not work correctly … I tried in all configuration modes! On Android Tablet I just need to connect the keyboard and mouse device via Bluetooth … I believe the app works normally.

Today I should have some time to do some more tests … Anything posted here …

Android TV do you connect to bluetooth through TvSettings?

Hello Lili, thanks for your attention … In the case of AndroidTV, my device connects normally, and his app does not work … In Android Tablet I believe the app works more, the device cannot connect!

I think on AndroidTV, TvSettings is used and that is why the bluetooth device works better.
Tablet Android firmware might not have the TvSettings app and the user might be using the green normal Settings app and it might have a bug with certain bluetooth devices, not sure.
Can perhaps check if tablet firmware has TvSettings and if not add it so user can test it.(Might need to remove the normal Settings app since it might cause problems)
I added a menu to TvSettings to open normal Settings app also on AndroidTV firmware and changed the priority of normal Settings app to lower values so TvSettings are used by default in Androidmanifest.xml file.

For AndroidTV - App problem
Choose the top Gear icon to open TvSettings
Go to Apps
See all apps
Click on your installed app
Scroll down to the last Setting - UI Mode
Change the UI Mode to Normal, Desk, Car, Television, Appliance, Watch or Vr-headset.
The default value is Television except for some apps that are already in a whitelist like Amazon Prime Video, Google Movies(both of which are Normal and not Television)

Try to clear cache of your app, grant it all permissions and then change the UI Mode to Normal or Appliance and test again.
This will make the app use tablet UI and not AndroidTV(Television) UI interface and might fix the problem.
If this still doesn’t work then the app might check permissions in /system/etc that is only available in tablet firmware and which is different in AndroidTV.
A logcat will show which permissions your app needs.
Also upload a link to the app if you can, perhaps we can test it to get it to work.
Are you using this app and the latest version?

Hello mo123, first thanks for your attention and help! Yes I have already tested the APP in all UI configs and it does not work properly … I will give you the link of the APP for you to try to test it, although you would need the device to fully test the APP …

The product I want to try to connect to the Android tablet is this …

The APP used with the device is this …

The APP on androidTV does not work correctly, in case you cannot find the game to map the keys … The device does not complete connectivity on the Android tablet! On androidTV it connects perfectly!

mo123 for you to get a sense … My mi band 4 from xiaomi does not connect to the Android tablet either … I think this can help with the problem!