How to make imx219 camera run @ 1920x1080 48fps


#1

Hello, all

Does anyone know how to get the best performance for imx219 camera?

I found this commit in kernel, and wonder how to test this function.

commit e9b2399061a941109da39ec6d80a9d746b7525b3
Author: Jacob Chen jacob2.chen@rock-chips.com
Date: Thu Jan 4 11:27:27 2018 +0800

media: i2c: imx219: support 1920108048fps mode

and correct some control to make 3A work

Change-Id: Id3fc3ca9c5b123b6d45cd80d8e857a5c151c2427
Signed-off-by: Jacob Chen jacob2.chen@rock-chips.com

BTW, my target board is running on debian.

And for your reference, the test_camera.sh fails when i changed the resolution to 1920x1080.

$ gst-launch-1.0 rkcamsrc device=/dev/video0 io-mode=4 isp-mode=0A ! videoconvert ! video/x-raw,format=NV12,width=1920,height=1080 ! rkximagesink

Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstRKCamSrc:rkcamsrc0: Failed to allocate required memory.
Additional debug info:
rkcamsrc/rkcamsrc.c(509): gst_rkcamsrc_decide_allocation (): /GstPipeline:pipeline0/GstRKCamSrc:rkcamsrc0:
Buffer pool activation failed
requesting 4 MMAP buffersExecution ended after 0:00:00.349467850
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

Thanks!


#2

hi wozuying
i tested my rockpi4b platform with your command,but it’s work

linaro@linaro-alip:/usr/local/bin$ gst-launch-1.0 rkcamsrc device=/dev/video0 io-mode=4 isp-mode=0A ! videoconvert ! video/x-raw,format=NV12,width=1920,height=1080 ! rkximagesink
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

my kernel is

linaro@linaro-alip:/usr/local/bin$ uname -a 
Linux linaro-alip 4.4.154-78-rockchip-00017-g625c2b2 #2 SMP Thu Mar 28 20:07:37 CST 2019 aarch64 GNU/Linux

if the version is different ,you can update follow https://wiki.radxa.com/Rockpi4/radxa-apt

thanks


#3

btw,my monitor resolution is 2560*1440,and your’s?


#4

under 2560*1440, i guess.
let me check.


#5

it shows 1920x1080.

$ xdpyinfo | grep dimensions
dimensions: 1920x1080 pixels (508x285 millimeters)


#6

the issue occured when rockpi4b output timing is 1920x1080,the log is same to you

linaro@linaro-alip:~$ test_camera.sh 
Start MIPI CSI Camera Preview!
/usr/local/bin/test_camera.sh: 9: /usr/local/bin/test_camera.sh: cannot create /sys/module/video_rkisp1/parameters/rkisp1_debug: Permission denied
3A disabled
/usr/local/bin/test_camera.sh: 12: /usr/local/bin/test_camera.sh: ehco: not found
Password: 
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstRKCamSrc:rkcamsrc0: Failed to allocate required memory.
Additional debug info:
rkcamsrc/rkcamsrc.c(509): gst_rkcamsrc_decide_allocation (): /GstPipeline:pipeline0/GstRKCamSrc:rkcamsrc0:
Buffer pool activation failed
requesting 4 MMAP buffersExecution ended after 0:00:00.330818917
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

so can you improving output resolution higher than 1920x1080?


#7

I see.

Thank you for you confirm.