How to install PoE HAT's software on Armbian

We provide software support to help you control PoE fan, and a one-click installation script and manual installation steps are provided on PoE HAT.

If you use Rasbian on Raspberry Pi or an officially supported system on ROCK Pi 4, you can use the one-click installation script. We are adding more system support to the installation script.

Here are the detailed steps to manually install the software on Armbian of ROCK Pi 4.

1. Enable hardware resources

We provide a dtbo file, please follow these steps to install it in Armbian to enable PWM and ADC.

sudo mkdir -p /boot/overlay-user
curl -sL -o rockpi-poe.dtbo
sudo mv rockpi-poe.dtbo /boot/overlay-user/rockpi-poe.dtbo

Then edit /boot/armbianEnv.txt and add rockpi-poe to user_overlays.

2. Install GPIO control library

Please install libmraa-rockpi4 from testing repo of Radxa APT.

3. Download package and install

sudo dpkg -i rockpi-poe-0.13.deb

4. Enable service

sudo systemctl enable rockpi-poe.service

1 Like

The download is dead
have anyone downloadet the deb and can share a link.


Sorry the link is broken, please use the address below

thx for the fixed link :smiley: @setq

This link is broken too🤷🏻‍♀️

The link is not broken, only hotlink protection is enabled. Using curl or wget access is fine.

Yes, the link works. :ok_hand: But it may be worth fixing the link on the wiki.

My bad. Thank you for reminding me.

Sorry to bother you guys again, but the fan still doesn’t work for latest armbian buster with 5.4.32:
I could get the dependencies done and installed/upgraded python. I had no errors during the install following the info here. Matter of fact, I get a nice
[ OK ] Started Rockpi PoE-FAN. I double checked overlay-user folder and the armbianENV.txt entry (user_overlays=rockpi-poe). libmraa (not libmraa-rockpi) was nicely installed and I checked using:
python3 -c “exec(‘import mraa\nprint(mraa.getVersion())’)”

What else am I missing?
When I boot into official debian9, the fan starts during startup and slows down later, with armbian it stays silent…

/e: Works smoothly now, boots fast, reinstalled libmraa (for whatever reason, I basically followed all steps again and checked after each; reinstalling libmraa was the point oO)