How to boot on nvme with Debian?

I’ve installed 10 times Debian on nvme but cannot boot on it.

Booted from USB stick with the installation software,.boot on USB is ok, but what settings on Bios, what choices in the Debian install app?

1 Like

Same question on WIN10, probably one of the driver files from the github, but not 100% sure

1 Like

Try installing RTC battery. I succeed to boot with win11 and ubuntu22.04.

Yes, thanks, that’s what I was thinking… There is no indication what is the model of battery, fuck.

Yesterday I was in front of a lot of choice and did not found on Radxa website the reference for the battery.

If this is the solution, I’ve lost 2 days because of this.

It’s literally is stocked post in x2l subforum, what do you mean
“No indication”???

I am blind color, my wife told me it’s written here, in red with black background.

Installed the CR1220, installed with another nvme and it was ok under 15 minutes.

Sorry, I was angry angry angry…

Feel badly NOT. IVE BEEN LOOKING FOR 3 DAYS FOR what kind of battery, and now that I believe it’s the 1220 I have 3 of the wrong size…sigh

Being color challenged does make life tough sometimes, like resistors, been in use what 100 years and we still depend on a strip of paint the size of a hair?

1 Like

Thanks for your message. For the resistors, I use a multimeter to confirm the value, impossible for me to read the colors.

I am pretty happy with the Radxa X2L and Debian. I tested with some Docker containers as a server then used Tasksel to install KDE Plasma and used it as a desktop computer. No problem for my daily tasks. I am a coder but mainly work on cloud computers and for Visual Studio Code or dBeaver, the Radxa is ok. Also I use youtube where I can find a lot of how-to and it’s doable with the card.

Finally I have only one complaints (if I avoid the lack of documentation right now): there is no USB-C connector for data; only for power, so it means I cannot take the card to go to the factory and plug it to the USB-C box connecting to keyboard, mouse, screens, lan etc… Not hugely important, just some comfort.

Really happy with the card… Now I want to use the RP2040 but was unable to do anything with Thonny yesterday, I guess I have to wait some documentation.

I too lost several hours to this while trying to install Windows 10, it kept hanging randomly, I’ve tried multiple USB devices. If this is really the cause (I’m getting a CR1220 in a couple of days) then the unit should ship with a battery by default.

It should but the reason is probably that shipping a battery requires a lot more paperwork.


That maybe your power supply can not support USB C PD?

12V is required for the X2L.

Some basic documentation about how to program rp2040 can be found here:

1 Like

I finally understood few thinks and was able to program some neopixel ring animation. Maybe I can explain few things here?

Please start a new thread specific to that topic.

I bought the Radxa Power PD 30W, is this not the right one?

Edit: Got a battery, still hangs. When booting Windows 10 USB installation media (I’ve tried several types) it looks like this, is this normal?

All I have plugged in is a USB keyboard, USB 256GB SanDisk UltraFit, Crucial 500GB M.2. NVME (when I got far enough in windows install it showed up just fine).