How can I get armbian for Rockpi 4c+

I have installed the 4c version of armbian to my 4c+, but all usbs can’t use except 3.0 otg. How can I get 4c+ version of armbian?

Armbian hasn’t support 4C Plus yet. Can you try the images here:

Thanks, when will 4c+ support armbian?

We are working on it. Armbian requires recent kernel and patches for 4C Plus will be sent to mainline soon. We expect Armbian support will be merged in Sep.

Is there any update on this? We need Debian bullseye for Model C Plus with Kernel 5.15+. Any ETA on this? I used Radxa-builder to create an image for Model C plus but it created bullseye with Kernel 4.4 instead and there wasn’t any instructions of making an image with a more recent kernel.

you can build 5.19.x kernel with bsp

./bsp linux latest

there is pending patch for ROCK 4C+

if you need these functions, please apply patch manually for now…

so if I understand this correctly, this would build the Debian packages for Kernel 5.19 and then have to copy the deb packages over and install them? is there a way to generate an image (.img) with Kernel 5.19 directly?

We just need minimal Bullseye + Kernel 5.19 + CLI (no desktop environment) to work with the RockPI C Plus model.

Complete this and you can build any combination of user land you need with kernel 5.15.y and 5.19.y

there is a way to use custom kernel package for building image with rbuild, e.g.

rbuild -k path/to/kernel.deb rock-pi-4c-plus

please check rbuild -h too.

by the way bsp/rbuild tools are still in development, they are not finished yet.
sorry for this inconvenience.

I would love to be able to build an image using a custom kernel, though I am getting lost in the weeds when it comes to the documentation.

Well, I think I built an image successfully. But I cannot login.
I thought the default user/password should be radax/radax as the says.
And I tried root/root, rock/rock, etc… No luck.
Any suggestion?

If you are building Armbian, perhaps follow Armbian documentation. Armbian is not Radxa product. They make hardware.

Thanks for the quick reply. Actually, I use bsp/rbuild. So, still no luck… But I will try armbian!

4c+ is not supported yet.

really sorry, currently there is no user bug in rbuild…

EDIT: no user bug is fixed. please rebuild rootfs (rbuild image) with -r option.

No worries. It’s fun to play around.

Now I can login. Thanks for your help. I will give it a little bit of test today.

It looks like eth0 is down after apt update/upgrade and reboot.
I guess this is a known issue?

BTW, which defconfig file is used for kernel compiling? Because I also want to test some kernel feature, like NETFILTER_XT_MATCH_SOCKET.

When is Armbian expected to support Rock PI 4 C+?

probably better to ask on ?

If you are a business client and wants to sponsor development

We are actually expecting Radxa to provide a working image with Debian Bullseye + Kernel 5.15+ for the C Plus model. So far no working image we can use in our product.