Help With Booting a 5B?

I added a 128g m.2 to the OPI5, and a WiFi usb. Ran it for several days straight on a shelf not a blip. Added some stick on heat sinks. ( have a metal frame/heatsink thing coming )

Had a little bit of trouble getting Armbian ( either real, or Oranges’s version ) to install to m.2 from a SD boot using the stock tools, so i just dug out a m.2/usb adapter and flashed it directly. Also did an upgrade to bookworm. Not tried to get GPU drivers to work yet. no hurry. at least it boots and runs…

I do think ill avoid bouncing it on the floor as a test tho :slight_smile:

Not the best test to run on your only working unit. :wink:

FWIW, it slid off of the laptop tray I was using on the couch while I was trying to set the tray on the coffee table…

Hey Ziggy, not sure if you have looked at this, but I have been using a RPi to monitor the ROCK 5B serial output. The reason I do that is I have no serial port adapter I can use with a PC which will go up to 1.5 Mega-bps. If you use your Orange Pi this way, (connect DIP header pin 6 {gnd} on each together, cross-connect pins 8 and 10 {rx and tx} on the header) you should be able to set up minicom on the Orange Pi to work at that baud rate.

I can try, but i do have regular UART cables. Both rated for over 1.5mb ( and work elsewhere )

I did try one of the recent unofficial Amrbian images from bables, and got uart once, tho gibberish. First time i had seen the board to do anything at all other than SPI flash. Then it all fell apart and it stopped doing even that.

Since i cant comment in the other thread as it was closed, and I would like to give credit when due i will do it here.

While it took a long time, Radxa did finally hear my plea for help. They got in touch with Allnet for me, and we worked out a return.

So its going back next week.


Congratulations. Hopefully your experience with the Rock5b will get better. Good luck

Congrats. For a moment I thought u were the guy who threw his to the lake… at least you were smart to make ‘some noise’ and get it sorted. If you need help come discord for a closer approach. Some do bite… but we are all humans fs.

I just bought two Rock 5B boards from a German supplier and got to this thread due to no serial output at all. I only want to share what was the issue in my case.

Initially I tried to just boot without eMMC and SD, 5V power via GPIO headers, CP2104 (from Firefly working well on a RK3399 board) connected to GPIO #6, #8, #10. My expectation was to see at least the output of the initial bootloader(s). But both boards behaved the same with consuming ~1W power, but showing no output, LED staying green.

I finally got it working after reading that SD card overrides SPI flash content and the boards probably came with empty SPI. Using a 32GB SD card with just idbootloader and u-boot flashed resulted in power consumption going up to ~2.5W and the LED turing blue, but still no output. Additionally, I had to switch TX/RX connections on the CP2104 despite connecting them crossed initially (TX->RX, RX->TX). The markings are possibly wrong. The 1.5Mbaud wasn’t an issue at all with the CP2104 which is no suprise as it should support up to 2M.

Thanks for sharing this idea.

When something is wrong sooner or later I’m trying some basic set, including the one with sdcard. Board need something to boot from and of course it will play death without boot medium.

Doubt anyone is reading this thread now, but the board made it back to them, they diagnosed it was a bad power supply chip. So, it really was a hardware problem and not me ( i dont see how it could have been… but nice to know for sure ).

Its going to be repaired and sent back. So i will give them credit for helping out once they heard.


Thank for information,
Still it’s unknown what is the cause of that failure, is that faulty chip or was it damaged at some stage?
Same thing is not uncommon on raspberry pi world, sometimes caused by overheating and overclocking.

Since it was non-functional the first time i tried to power the board up, i suspect a faulty or weak chip from the start. I never had a chance to kill it from over-use or anything.

Unsure if they check the boards in any way electrically before shipment or if they get packaged right off the line.

Of course all boards are tested at factory for many small things, but this will never cover every single aspect. Read more about that on ROCK 3A defect notice so You will get idea how this works. Radxa is doing their best to catch as much as possible faulty boards on production and probably Your board was ok at that time.

Your sbc could be damaged in transport or even by ESD by Your touch, other possibilities are with Your charger, heat, moisture, handling, bad cable and possibly many other unfortunate things, we can only guess. Of course also it could have some IC defect that occured later and then probably more boards will share same problem (let’s hope it’s not that). Hopefully when You receive replaced board You will be able to run it.

Considering i use the same charger now for my Orange pi 5, i dont think its the power source.

Yes. ESD is always possible. but doubtful i caused it as i have never burnt a device yet that way, and been in the IT business since the late 80s. ( i actually have a loose ground plane i touch before i grab boards around here. Never burnt anything but i have a PC that will instantly reboot on ESD when you shove a usb stick in )

But they did assure me this was tested so im sure it will be fine this time.

Well its back. Booted right up the first time. Lots of frustration for nothing the last few months, but explains why nothing i did worked. Just so strange it was alive enough to flash it… would have thought it would be 100% dead due to a bad power chip. But whatever, its here, its been running for 3 hours now and that is what counts.

Had them ship a case too, as they now have an official metal case. Too bad the sides panels are green… yes… GREEN…

Any statement about defective chip? Was that just replaced?
Is that part available to resolder it locally?

They didnt say how it was defective, just that it was and they had replaced it and things tested fine.

Without looking at the schematic to see if there was some sort of direct to bus bypass going on too, my guess is that even tho it was bad, it was still passing thru slight current so a few things that didn’t need CPU worked ( lights, fan, flash ) but would not pass enough to bring up the CPU and peripherals fully ( but enough to get the CPU to warm a little ), and why it seemed like a PSU issue instead. Well, i guess it was technically a PSU issue, but not an external problem like it seemed to be. ( or as a couple of unnamed people, thinking it was that i was incompetent… )

I didnt ask for details on the chip specs, but i would imagine its a commodity part and could be sourced.

I literally had the same issue booting up today using a usb-c 45 watt adapter off amazon. Two things I realized I did wrong after getting it to work. First the sd card gold contacts should face up and second the green light will illuminate with the cable not fully seated. I unplugged and pushed pretty firmly to seat it fully and it began to run the sd load. Not sure if anyone else has experienced this but don’t let the green light fool you, you must firmly seat the power supply otherwise the green light will illuminate but I’m assuming not enough contact for the power needed. Hope this helps!

Interesting :slight_smile: I never was able to plugin in usb-c half way :slight_smile:

Never heard of that before either.