Help With Booting a 5B?

I know others have had issues, but after trying everything, nothing works for me so some advice of next steps?

I am able to flash SPI so board is not dead.
Various power supplies recommended on here, including the OEM one. The last one i tried was the ugreen, but also tried 12v with a barrel to USB adapter, same results ( below )
Various SD cards, using etcher ( however all verified and could mount on my Debian host machine. )

  • With Radxa images, i get boot loops. ( green, blue, green, blue, green, rinse repeat )
  • Armbian it turns blue and that is it.
  • No light for network, not even just showing its connected to the switch…
  • No HDMI signal
  • No fan ( i assume OS will drive that, not the board )
  • Nothing on serial console, using Radxa instructions. GPIO pins 6,8,10. Even went and bought their suggested cable due to the 1.5mb default baud rate… ( 1.5m?!? )

Hi, ziggy.
In my environment, a 12v with a barrel to USB-C Adapter works well even though an Anker 65W A2712 causes the boot loop.

So, Please try the image of [].

My 5B with the image could boot well with any power supplies I have (an Anker 65W PD, Raspi 5V 3A PS, 12V with barrel to C, etc). If possible erase the spi nor flash just be sure. (
However, the boot loop appeared when I installed task-xfce-desktop and rebooted it.
I hope the 12V with USB-C PS works well after erasing the SPI Nor Flash.

That image was one i did try. I have been trying every Radxa ( and Armbian when those appeared ) release since i got the board, hoping one would work.

After i had zero luck with any usbC supply i had already, i bought a 60 watt 12v barrel, + usbC adapter so i still have that available. However, the last couple of attempts i only used the OEM and ugreen that several people around here said worked for them, so i guess it wont hurt to try it again with the generic 12v supply.

I cant even count how many times i have tried with so many adapters+builds+SPI. Trying every combination, hoping.

And i didnt mention i do erase every time i flashed. Just out of habit. I forget not everyone does that. ( SPI, eMMC, and SD cards )

EDIT: used your suggested image + 12v Barrel. Back to boot loops like i got with the OEM or UGreen. ( according to the light ). Using debug enabled SPI.

note i do NOT have eMMC or m.2 installed to add to possible problems. its just SD. ( but when i was still trying eMMC, was getting same results )

So frustrating. ( and i was one of the early reservists, back in early Jan so it got here long before the holidays. Not yet got to see it boot even once… )

OK, sorry for taking your time. pls forget my comment.

No, its ok, you were trying to be helpful. Im at a loss so i appreciate it.

I would only try it with the fixed 12V 60W supply. At least until you get something booting.

Remove all peripherals.

You may be unlucky that the SD card is not compatible.

Is uboot on the image that is flashed to SD? You will want to boot from that if you are not certain if spi flash boot is valid.

You may need to write the loader and uboot to the SD card. The idbloader/spl should already send something out on the serial console.

If loader is present on SD, it has priority over the loader on spi

Nothing else is plugged in. Multiple SD cards and multiple eMMC cards on earlier attempts. And i agree i should be seeing something on console, even during a non-boot event. But dont get anything.

I would assume the radxa images have uboot in them already? Or do you mean they do not and this must be added manually, even to theirs?

Don’t know if they have a loader on it. You could write the latest anyway, as described in wiki.

If you make a card with my archlinux install script, I know this has the loader installed on SD card. For other images I do not know if they have it, or rely on spi for the loader…

Ill go look into that then.

EDIT: so i dont have to search forever, have a link handy to the wiki page that shows this?

NM i think this is it ->

Option 3: Write bootloader only to microSD

1 Like

That seems easier than the one i was looking at as you had to build the stuff first. ( not hard, just more steps )

EDIT, looks like the files are here ( my link was about building them from scratch )

EDIT 2 - Well, same results. Getting annoyed with it again so i need to put it away. If it had not been so long id be looking into how to return it and go find something else, even an S version. Was looking forward to upgrading my RK3399, but alas i think i just have myself a door stop.

( just ordered a Nano PI-R6S… its an S, so it does not have the same amount I/O but at least i know it will work out of the box. Used FriendlyArm products for years, both personal and for products… never had an issue )

1.5M is default baud rate for all rockchips, and it’s not a problem for most wired console cables, but still there are some that don’t work. I also bought console that looks exactly like the one from wiki and that one is not working. FTDI has some issues and needed driver, but WCH341A and WCH343 (even better) worked fine out of box. That last one is capable of 6M baud rate.
Are You sure rx tx lines are not reversed?

As far as I remember I had same issues before bootloader was updated, but always watched everything on console to see if there is any error or bootloop. Get any cheap WCH341A and try again - they are everywhere and (except one of my rock3) it always worked.

I got a WCH340, so ill see if i can find a 343 out on amazon ( so it wont take a month to get to me coming direct from mainland or HK ). I have another that i normally use, but i dont think it can handle the speed so i never even tried it. unsure the chip, the ink has long since rubbed off.

Running linux on my ‘host’, and it does see the cable just fine, so wasn’t a driver issue. If it was just baud rate, id expect to see garbage at least. But ill look for another one as you suggest, and try that. And ya, i did swap the rx/tx lines, just in case the colors were wrong. It happens from time to time.

Might be default for RK but 1.5m just seemed high to me. Not that it mattered, just seemed odd was all.

WCH340 supports up to 2M baud rates, I got WCH340G variant and it works great with rock5.
WCH343 is still quite new, I’ve got mine from waveshare.

right, the 340 should have worked… but its only a few bucks for another cable.

If you’re having boot issues, I suggest using instead, since it has serial output in u-boot, unlike release

As mentioned, i did.

You can try another sd card >8GB+ with original radxa image.
Just with SD-Card it shoud boot with 5V.

If you have emmc or NVME attached it wont boot unless you give 9-12V.
If this is a new board you always can contact customer support.


As mentioned i have tired several SD cards, and at this moment there is nothing else plugged in, no eMMC, no M,2, fan, HDMI… nothing other than power ( several of them too )

Also as mentioned, unfortunately i was one of the super early reservists, so i got mine in the 2nd batch, so not new. Everyone was having issues so i didnt ask to return it then and thought id wait it out. Now i wish i had as it seems like i got a dud…

And sorry for sounding snotty, its not you, thanks for suggestions, im just frustrated. Going to put it away for a bit.

1 Like

Do you get any serial output from the bootloader?