HELP, no mic signals on some rockpi4

I get 2 rockp4a (hardware version 114-173) two weeks ago. I download image file named rockpi4a_debian_buster_xfce4_arm64_20210824_0245 -gpt.img.gz from github site.

I use them for an voice chat node, so I plug in a wireless mic. It seems ok except one of them can’t get mic’s signals.
Then I get a third last week to replace the bad one, the problem was solved.
I tried the native mic also, and found the same thing: no sound can be record.
So, what’s the problem?

I test the mic using the command:
rock@rockpi4a:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: rockchipes8316c [rockchip,es8316-codec], device 0: ff880000.i2s-ES8316 HiFi ES8316 HiFi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: MIC [USB MIC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

rock@rockpi4a:~$ arecord -d 10 -f cd -r 44100 -c 2 -t wav test_native.wav
rock@rockpi4a:~$ arecord -Dplughw:2,0 -d 10 -f cd -r 44100 -c 2 -t wav test_plugin.wav
rock@rockpi4a:~$ aplay test_native.wav
no sound heard
rock@rockpi4a:~$ aplay test_plugin.wav
no sound heard
rock@rockpi4a:~$ aplay /usr/share/sounds/alsa/Rear_Left.wav
sound heard

Please try with the latest image. The one you were using is quite old by now.