Green LED, Doesn't Boot

I recently got a 5B, had it boot Debian today, was looking at getting the camera connected, after some digging, the Debian kernel seems older and the forums here had a post about Ubuntu, so I switched to Ubuntu on the SD card and now I only get a green LED, no booting that I can see, no link LED on the NIC, no external video (1920x1200 via HDMI 1), nothing. Any magic to holding down power or reset to try and get it boot again? I tried unplugging everything except power, no change. Power supply is the one that is sold with the 5B board on AllNet and was working earlier today with Debian. Reverting to Debian doesn’t change the situation.

You could try flashing the sdcard again. Green LED means cannot find bootable files AFAIK.

I tried switching between Debian and Ubuntu, but this time I wiped the partitions first and re-imaged the microSD. No change, just a green light. From what I understand, green means it has power.

yes, and probably no bootable device
if You updated bootloader and mtd block it may seek for eMMC or something else only.
uart console sometimes helps to understand what is going on there

I had done whatever updates were available after first boot with Debian and had rebooted a few times updating boot.cfg to get the camera to work. It only stopped working when I switched to Ubuntu, so, not sure when would have changed the bootloader.

If you once had it working using Debian on an SD card with your current power supply then I would suggest to boot it in maskrom mode and erase the SPI NOR to try to get back to that state and try to boot from the SD card, My machine won’t boot off the SD card if the NVMe boot code has been loaded into the SPI NOR, so if you did that and the NVMe can’t boot for any reason you may also be unable to boot from SD card, whether or not you have a properly flashed SD card.

The instructions on how to boot into maskrom mode and how to program and how to erase the SPI NOR are on this page:
https://wiki.radxa.com/Rock5/install/spi

It should be noted that when you boot into maskrom mode the LED on the device will be solid green the entire time. If your light turns blue at all then you are not in maskrom mode. However, the LED is also always green if you just have no working operating system installed for the machine to boot from so you might not be able to tell the difference between those two except by the way that the PC that you connect to for programming it in maskrom mode detects it.

I must be doing something wrong as I get nothing going the SPI route, it doesn’t see a USB device. I also tried UART TTL and got nothing there either.

Check if your ROCK 5B is dead first:

https://wiki.radxa.com/Rock5/FAQs#Boot

That is like the SPI above, and seems dead, no USB device shows up, tried different USB ports.

If you have cleared the SPI or never programmed the SPI and there’s also no valid EMMC or SD card to boot off of then the rock5b appears to put itself into Maskrom mode the same as it would if you connected power to the rock5b while you are holding down the maskrom button. In that mode the LED stays green and there is no TTL console output.

If you have a properly programmed SD card but you have it in the slot upside down you could boot in this state if your SPI has not been programmed. I did that the other day before posting here that my machine couldn’t boot from SD after installing the SPI. It turned out that it could boot from the SD with the SPI programmed, but I had the SD plugged in upside down at the time so it wasn’t actually seeing the SD.

If the SPI NOR, SD card, or EMMC has been programmed with radxa’s debug or release u-boot firmware then when u-boot begins to run it turns the blue LED on. If the LED just stays blue forever after that then the machine ran u-boot, it was unable to finish booting for some reason. The most likely reason is because you booted from SPI which has the u-boot bootloader, but it doesn’t actually have any boot image and it couldn’t find a boot image anywhere on the SD, EMMC, NVME, USB, or via PXE network boot. Both the debug and the release SPI firmware will show the preloader boot log on the TTL console. The debug version will also show u-boot’s boot log on the TTL console.

If u-boot is able to boot radxa’s version of Ubuntu or Debian then the blue LED will go into heartbeat mode where it flashes blue twice every second or second and a half, something like that and it will be green the rest of the time If your machine does that then you should be able to make a text-mode terminal connection to login from another machine via SSH over the ethernet connection and unless you have some kind of problem with the video drivers or video mode configuration you should be able to also see the GUI boot up on HDMI and login locally with keyboard and mouse.

In your case all you see is green and you have no debug output so you are likely in Maskrom mode. I don’t know why you wouldn’t be able to see the device via USB connection though. Some kind of device should be detected in Windows if you connect a USB-C to USB-A cable from a USB3 port on your PC to the USB-C port on the Rock5b. When the device is detected right after plugging it in, Windows should make a noise indicating that. You don’t even need a power supply for the programming of it in maskrom mode since it will be connected to your PC.

If your Windows machine isn’t making a noise indicating that the device is being connected each time you connect it, then something may be wrong with your USB cable, with the USB port you are trying to plug it into, or with the Rock5b itself. I would start by trying to plug it into a different USB port and if that doesn’t work trying a different USB cable. If neither of those things helps and you don’t get any kind of sound when plugging it into your USB port in Windows, I would say that you may have a device with a damaged USB port or some other hardware damage and you should try to contact Radxa or whichever vendor you purchased the machine from to inquire about warranty/RMA service.

And now it seems just dead, no green LED anymore. Will contact support…

No green LED means the board isn’t even getting power, as the green LED is AFAIK hardwired to the 5V power plane. So, that’s either a dead onboard buck regulator, or a dead power supply.

Some PD chargers are not working at all with board and no green led on board even though it’s working with other devices (at full pd speed). So don’t expect that this led light means just power - rather it is something step further.
My advice is to test more than one charger or so called “dump 12V” via usb-c cable. I’m quite sure that my charger where rock5 plays death was working earlier, for sure I updated several things trying to get my nvme working.

I have tried a couple different power sources, it seems dead dead, note that originally it was working with the one purchased from the AllNetChina store with the board itself. I’m looking into returning it.

My board also died…
I had some random reboots on debian sdcard, and I was able to boot from nvm drive after SPI flashing…
But after a while the board didn’t boot at all, only green light, and nothing else.
I got in contact with the Raxda support and thay asked me to try to boot in the maskrom boot. If your pc can’t see the usb device in RKDevTool.exe your board ist surely also done…
Wrote today a request for replacement… we will see :slight_smile:

I wrote Radxa and they said to contact the seller (AllNetChina), so I wrote them 2 days ago, no answer yet.

My board died also…
I’ve sent an email but no news from AllnetChina… There is not any support way on their website, and they are not answering in the chat.

I managed to get a hold of someone and sent mine back. Shipping requires tracking which means it won’t be cheap to send back. DM me for contact.