Graphical window stopped working after apt update and upgrade and a reboot

Hello,

sorry for this help seeking thread, I am a user, not a professional. Please let us not discuss how a normal user can buy such a experimental sbc… I know.

I updated the SPI to boot from my Intel SSD 660p, 512GB PCIe 3 X4 with success with the tutorial found at https://wiki.radxa.com/Rock5/install/spi .

Then installed the debian image over USB-adapter from my linux-pc
https://github.com/radxa/debos-radxa/releases/download/20221031-1045/rock-5b-debian-bullseye-xfce4-arm64-20221031-1558-gpt.img.xz

The first boot with a 65W USB-C PD rebooted, then on the 2nd boot went to the graphical desktop. I ran the console and did sudo apt update and sudo apt upgrade, then sudo reboot.

After that I get the text linux boot screen for a second, and then a cursor blinks on top left of my screen (HDMI 1080p), the system does not go to the graphical desktop any more.

If you answer, please bear in mind that I am a user - please describe how to do the necessary steps to solve this problem. Thank you!

1 Like

There is the possibility that the display manager has crashed. I dont use Debian, but i believe Debian Bullseye is using gnome which i believe used gdm display manager.

Can you log in to the terminal by going in to the terminal mode ALT+F2 or CTRL+ALT+F2. I dont know which key combination makes you go to the CLI from desktop from GNOME.

If you manged to go to the CLI and log in using the user + password. Then type (command below) to see if the service is running or has failed or whatever. There you maybe also will see some error log what is going on.

sudo systemctl status gdm.service

1 Like

Thank you for your reply!

Sorry for the delayed answer, I waited for another power supply unit, that supplied 5V 10A with an barrel to USB-C adapter because the first one was defective.

input:
sudo systemctl status gdm.service
output:
gdm.service could not be found

Additionally I tried to input
startx
and see what the output was. Please see the attached mobile photo for the output (sorry for the quality).

Can you give the output of this command.

systemctl status display-manager

1 Like

Sure, and thank you for your help!

Can you do this

sudo apt install plymouth plymouth-themes

1 Like

Thank you again for your help.

But my failing eyesight seemed to have come together with a slight design oversight and missing screws for the case assembly.

I tried to screw on the SBC to the case bottom with the smallest screws I had found. There were no screws sent with the case, sadly. And there my luck came together and I might have damaged the SBC to an unknown amount by trying to assemble it to the case.

That alone tells me to never try to be curious about these things again - well, that’s my depression speaking.

What’s best, I could not even find the missing part again, how doubtfully it is that I can soldier it back with my eyes, even with a huge magnifying glass I have for “bigger” soldier work.

Right now I am just too frustrated to have spent over 400€ in parts and accessories to just destroy the whole project with one, and literally a “screw up”.

BTW

Selling the damaged SBC (with installed bootloader for SSD’s) plus
the case (black & green) from ameridroid (without screws to screw the SBC to the mounting plate, sad laugh)
another acrylic case without holes (yet)
a 5V 10A PSU from Leicke.de and a barrel-to-usb-c adapter
a 65W USB-C PD (power delivery) PSU that works plus a 1,5m braided cable
a 40x10 and 40x25 fan, one 6V one 12V, non-PWM 2-cable versions
a piece of 7Wk heat transfer pad fitting to the CPU
two full copper coolers, that won’t fit the board in version B from Enzotech, the CNB-S1 and the CNB-R1
an Intel 660p 512GB SSD, written once under 16GB with the debian version from radxa

for a reasonable price, buyer preferred with delivery address in Germany or EU.

Pick what you want and name the price in a PM if you are interested and skilled enough to replace and soldier the missing part (see above photo).

Hi, I have the exact same problem with “Failed to start Light Display Manager” and dwhdmi-rockchip fdea0000.hdmi: use tmds mode in dmesg.

I have installed the two plymouth packages above and also accountsservice as I was getting: rock-5b lightdm[1197]: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files

However, still no X graphical screen. It did work with the initial image on the SD card. Before the kernel upgrade.

Anyone have any ideas how to fix this?

Or - what’s the easiest way to go back to the previous kernel (I am familiar with grub2, I don’t see it here).

Rock 5B. Bullseye 64-bit. 5.10.110-34-rockchip-gca15bbe36e6c

Thanks in advance.

Hi, which image did you downloaded? Maybe you should find the newest from here: Rock 5 downloads and reflash your storage.
After boot don’t upgrade, and lets see what we have.

Hi there,
I’ve had the same problem with my Armbian Image. I had to copy again the Mali Firmware File to /lib/firmware/ and GUI is working again.
Andreas

Just install mali-g610-firmware from this repository:
ppa:liujianfeng1994/panfork-mesa.

While the display won’t work, your ssh server still does, so you can install it from there. Or switch the tty (Ctrl+Alt+F1 or F2 or F3…)

Thanks incognito,
thats exact what I mean.:smiley:

1 Like

I have the same problem: the only distro that works with my board is Ubuntu 20.04 without any upgrade. If I do an upgrade on reboot I have black screen.
Black screen too with all other distros, just flashed in my emmc (no upgrade at all).
This board is unusable in that way…

What if you first hold the kernel version and then do an update? Like so:
sudo apt-mark hold kernel_package_name