GPIO not working in latest linux images for ROCK-4SE

GPIOs 36,38,40 are listed by mraa-gpio list. But set output to 1 does not work despite command itself return no error. Voltage is not high level.
I’ve tried gpioset for appropriate kernel id gpios (132,134,135) with the same result.
This misbehavior is observed on latest official rock-4se_debian_bullseye_kde_b33.img.xz

On older official rockpi-4b-ubuntu-focal-server-arm64-20221109-1331-gpt.img.xz It works OK via sysfs.

I have new findings regarding issue. It is about device tree file.
Older image rockpi-4b-ubuntu-focal-server-arm64-20221109-1331-gpt.img.xz with kernel 4.4 is loading rk3399-rock-pi-4b.dtb on uboot. current images with kernel 5.10 using rk3399-rock-4se.dtb.
When I mannuale changed dtb to old one on 5.10 based system then GPIOs works. This is not a final solution what I wish stick to. So I am digging deeper in arch rk3399 device tree files.

Am I only one here who is facing this issue? I consider it as basic functionality.

1 Like