FreeBSD 13-CURRENT on Rock Pi4

Hi.

Updated links to boot images.
Added XFCE Desktop.

1 Like

hmmm… have tried mouse and keyboard in all four USB ports, don’t work at all, they work fine with linux and android…
Rob

This must be 4c as 4c have a different usb requirement.

Yep, that is the case. Any idea when there will be BSD for the 4c?

I will share 4c dts patch to @SleepWalker then he can look into it when he gets time.

where can i find dts file for Rock-Pi-4c?

Hello,

This is the patch to fix usb for rockpi4c while the rest of the dts stays the same.

So we basically have 3 dtb for each model released

  • rk3399-rock-pi-4a.dtb
  • rk3399-rock-pi-4b.dtb
  • rk3399-rock-pi-4c.dtb
1 Like

Hello Radxa community!

New Years, a new FreeBSD XFCE DESKTOP installation image is available
for download on the new site. https://personalbsd.org

HDMI audio works now !!!

You can get your FreeBSD XFCE DESKTOP audio experience on Rock Pi4 A/B

All six cores are working now.

Good luck everyone.

PS:
I will be pleased if you leave comments about your experience and my images on this forum,
or on my website https://personalbsd.org/#respond

1 Like

The latest u-boot in ports actually has board support for the 4c. I was able to create a bootable image just by changing the BOARD_CONFIG to rock-pi-4c-rk3399_defconfig

They won’t work because the wrong dtb is being loaded. If you want to get this to work, you can do the following (on a freebsd machine)

  1. On your FreeBSD machine (or in a VM) goto /usr/ports/sysutils/u-boot-rock-pi-4
  2. Edit the Makefile and change BOARD_CONFIG to rock-pi-4c-rk3399_defconfig
  3. Build that port
  4. Download the official rockpro64 image for freebsd and unxz it
  5. Write the image to your emmc/SD card
  6. Then write the uboot with the port you built:

dd if=/usr/local/share/u-boot/u-boot-rock-pi-4/idbloader.img of=/path/to/sdcarddevice seek=64 bs=512 conv=sync
dd if=/usr/local/share/u-boot/u-boot-rock-pi-4/u-boot.itb of=/path/to/sdcarddevice seek=16384 bs=512 conv=sync

Then that emmc will boot into freebsd with USB etc enabled

I’ve tried this myself with a snapshot image and everything (except NVME) works

Does NVME work on your boards?

Check out this image.

FreeBSD-aarch64-13.0-RELEASE-Rock-Pi-4c-20210420.img.xz

I don’t have Rock-Pi-4c so I can’t guarantee, but NVMe should work.

Thanks, yours is the original image I tried first off. It might just be my nvme card, but I notice this line in the dmesg of this thread, as well as the dmesg of my machine:

Is that the issue, what is that line? Does it pertain to this:

https://www.freebsd.org/news/status/report-2019-10-2019-12/#RockChip-Support

“Known working devices are NVMe devices and PCIe cards that doesn’t utilize PCIe switching or bridge functionality.”

Is this something they can add or a hw limitation?

Have you tried using an NVME card on your 4a/4b?

I think I understand my mistake here. In my excitement to get going I accidentally ordered an M.2 SATA device instead of an M.2 NVMe… what a fool

Just tested it with a WDS500G2X0C and it works as expected. I have a bad habit of doing this, rushing to order things when I’m excited. haha, never mind I’ll use the other disk in another machine that has a slow sata.

1 Like

Hi ,
I am eagerly awaiting my Rock Pi 4 E so this is a great help.
Have you pushed this up to FreeBSD?
If you agree, I can do this over the weekend. Of course I will give you full credit.
Philip

Hi Philip.
Bring this over to FreeBSD if you have some free time.
thanks

cool
if you want to appear on the commit, can you email me your name and email address so I can give you credit when I submit it.

1 Like

Hi Philip!

I am registered at https://reviews.freebsd.org/p/s199p.wa1k9r_gmail.com/
I would be glad if we can prepare good reviews together.
I’m bored doing it alone :wink:

New images!

FreeBSD-aarch64-13.0-RELEASE-Rock-Pi-4-20210420.img.xz

FreeBSD-aarch64-13.0-RELEASE-Rock-Pi-4c-20210420.img.xz

These images have U-boot, for SPI.
And you will be able to configure OS launch from NVMe directly.

1 Like

That’s a Little Bonus - OPNsense 21.1 for RADXA SBCs!

ROCK-PI-E
OPNsense-21.1-OpenSSL-aarch64-ROCK-PI-E-20210417.img.xz

ROCK-PI-4C
OPNsense-21.1-OpenSSL-aarch64-ROCK-PI-4c-20210417.img.xz

1 Like