First problem instalation nvme sorry my english

maybe Samsung EVO 970 not boot SPI, works well sd-boot with Armbian
i try other nvme ssd

Hi,

yes, I am sorry that in bootloader, the Samsung EVO 970 is not supported. You can try other nvme ssd now or wait for this issue fixed. As far as I know, @ayufanpl is also working on this to fix his Intel nvme ssd.

samsung says vs intel nvme
samsung nvme not boot, vs () intel, it boot fine

reading /extlinux/extlinux.conf
598 bytes read in 0 ms // intel (598 bytes read in 1 ms (584 KiB/s))
select kernel

reading /vmlinuz-4.4.154-90-rockchip-ga14f6502e045
ERROR: status = 2013, phase = 1, head = 1
Error reading cluster

Hello question every time I try a different operating system do I have to reinstall boot-spi in spi flash? I wanted to run armbian from ssd nvme after the problem I had with the debian image and it didn’t work. First I had to record the micro sd and now I’m going to repeat the spi flash process and only then will I try again with armbian de nvme. Will it always be like this every time you want to change your operating system?
And I have another question: if I wanted to run Dietpi, which is based on debian buster, how do I follow the radxan guide where it suggests, to record the spi flash image add the radxa repositories if these are strech?

Once you have written u-boot-spi in SPI Flash, you don’t need to write it again. As long as the firmware/distribution supports sysboot, the bootloader in SPI can boot it. So just write Dietpi to NVMe, and it should boot.

I had this issue>

Step one: upgrade bootloader on SPI Flash
grep: /proc/mtd: No such file or directory
Boot device, SPI Flash, is not found. Make sure there is one SPI Flash on board.
You can install package rockpi4-dtbo later manually and uncomment three lines in file /boot/hw_intfc.conf.
intfc:uart4=off
intfc:spi1=on
intfc:dtoverlay=spi1-flash
After restarting the Pi, execute command, /usr/local/sbin/rockpi4b_upgrade_bootloader.sh.

What’s the output of dmesg | grep spi

Maybe @Stephen have some ideas?

Bad news. I tried many times to boot from nvme without getting it. Yesterday from Debian Microsd I did not start the desktop and when trying to perform the procedure to start from nvme, the console was blinking, and without knowing that my ssd nvme was going to be ruined, I turned off the computer. Now I run out of ssd nvme, with how expensive it is, and unable to launch rock pi, because I wanted it for that, until I have a new nvme. I feel disappointed, because it was not supposed to be so difficult. I am deceived.

Not near to the time of people which are trying to help you.

For NVMe SSD, at least 3 years warranty. Just replace a new one if broken here in China. We have done that many times since we test the ssd a lot.

I bought this ssd from Aliexpress, but 15 days have passed since I declared the receipt of the item and I can no longer claim anything. So now I’m going to buy it in my country, but it will cost me more than double. I’m watching Adata XPG GAMMIX S11 Pro 256GB (AGAMMIXS11P-256GT-C) which is on the following page recognized as a device that works: https://wiki.radxa.com/Rockpi4/FAQs

This one is cheaper but I don’t know if it works:

XPG GAMMIX S5 PCIe Gen3x4 M.2 2280 512
https://www.adata.com/jo/specification/587
boot well when other pc flash .img to ssd
if try flash ssd in rockpi = kernel error

Works fine without SDcard, I am now happy, thanks for the code

Kingston 240GB A1000 SSD = PHISON PS5008-E8-10
does not read the kernel SPI boot(works with sdcard)

Samsung 250GB 970 EVO Plus SSD-levy, M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s
does not read the kernel SPI (works with sdcard)

Kingston A2000 not work = kernel error
Gigabyte m.2 2280 pciex2 and Intel M.2 NVME works fine and boot spi(not tested armbian)

1 Like

Hi. I don’t understand the meaning of the concept: does not read the kernel SPI (works with sdcard)

my bad english
not boot without sdcard…with SPI

Is there a way to verify if spi-flash is correctly installed from a rock pi 4 b with micro sd system? What commands should I run in the terminal to verify this?

You have many ssds lol

Gigabyte m.2 2280 pciex2 and Intel M.2 NVME works fine and boot spi(not tested armbian)

What are the detail Gigabyte and Intel model?

Yes, i have six M.2 NVME

Gigabyte Model:GP-GSM2NE8128GNTD
Intel SSD 660p Model:SSDPEKNW512GB

boot also SPI without SDcard armbian buster default, two tested with official u-boot
Gigabyte Model:GP-GSM2NE8128GNTD
Kingston A2000 M.2 2280 PCIe NVMe

AGAMMIXS5-512GT-c …unstable and heats up strongly
Samung 970EVO PLUS also heats up strongly
maybe some problem with PCIe power management

1 Like

Hi, I have a doubt. When I format the nvme ssd for the first time to record the debian image for example, should I format the ssd in gtp system? Or it does not matter, if one records the image with the dd function.
So far I had been recording the partition table in msdos.
Thank you

Yes. When you use dd the partition table format is set from the image you write.

I think you may be right there. Thats why some manufactures have heat sink or thermal conductive silicon pad for NVMe.