Faulty networking

Hello.

I bought a Rock Pi 4A (rev. 1.4) with all accesories back in december. It arrived just before new year, I loaded up an image: It booted fine, then I’ve put it in a box for later.
We are now later. I’ve got an up to date image of Armbian Buster 5.4 loaded and there is no way to have network working.

ethtool eth0 shows everything usual, the (1 G) link being detected and configured properly (LEDs are lit anyway).
DHCP is unable to get an IP address. So I investigated and found out that DHCP does get out of the pi, my router responds then nothing happens. Data can get out but not in.

Exact same behaviour with other flavours of Armbian and the official Ubuntu image. Of course I tried switching cables, even if everything works fine plugged into my computer. I even tried lowering link speed to 100 M (router configuration) and changing PSU.

To me that looks like a faulty BGA. Google gives multiple occurences of bad Ethernet on RP4 but usually it’s completely dead. Is there any known hardware issue ?
(Everything looks absolutely fine software-wise, except it’s not working.)

Thanks for your input.
Antoine.

Data can get out but not in

What if you set a static IP address, can you ping to the router? The possibility of faulty BGA happens is very very low. If it happens, it’s blocked inside the factory and will not pass the PCBA test.

Hello Jack.

I forgot to mention it. Static IP was the first thing I tried as I thought DHCP wasn’t working for some reason. No luck with it either. If I ping, it doesn’t come back.

After my first post I’ve let the pi sit there doing nothing. When I came back it was a great surprise to see that it had acquired an IP and network was working fine. So, DHCP works.
Yesterday I tried to reproduce it with success: once reported temp reached about 41°C, network started working.

I have the official heatsink so it takes time to heat up. I will run a benchmark on start in order to check that it is indeed heat and not time that is doing something.
Sadly, intermittent faults can pass factory checks.

Antoine.

Yesterday I tried to reproduce it with success: once reported temp reached about 41°C, network started working.

So you mean when it’s cold, network is not working, after the board is running warm, it starts working? This is the first time we’ve seen this issue. I think you are just unlucky(or maybe lucky). You can ask the distributor for a replacement. Please put some note in the package about the issue or just put the forum thread link in it.

Indeed.

I’ll do that. If it will ultimately get back to you, I can PM you the SN of the board.