Failed to boot Armbian from Rock PI4B v1.4

I tried boot armbian in Rock PI4B v1.4 but failed.
I tried using SDCard and EMMC but all in vain.
Any suggestion?

I suggest you try the official debian image first.

What is the diff 1.3 vs 1.4 ?

Thank you. I did try it
Yes. the officeial debian image and ubuntu server image work

Aha-a, probably this is the problem:

actually not, as I’ve been conducting all tests with the poe hat out

I’m also having problems booting from other images than the radxa ones, with the SPI enabled.
Once the SPI is disabled oficial armbian boots fine from the uSD

I followed the procedure to upgrade the bootloader (from debian package) and the erasing/writing to the flash seems to go fine.

Then I can boot directly from a HP 900 nvme or uSD with radxa debian stretch, but not with armbian stretch official image.

It seems the spi boot loader fails to boot from mbr storage.

I am facing this issue too.

With Radxa Buster in the eMMC:

  • Radxa Buster in the SD card boots
  • Armbian Buster current (with Linux 5.3.x) does not boot

I have Rock Pi v1.3 so no SPI flash. Updated to the latest packages and bootloader image on Radxa buster eMMC.

It was a compatibility problem with the Armbian image.
On modifying /boot/armbianEnv.txt as specified in step 5 in the following thread, it worked.