Ethernet Issue with Ubuntu 18.04.5

Seems to be an issue just with 18.04.x (I only tried 18.04.5). I was able to install 20.04 with no problems and ethernet worked right away, even on reboot. I’ve tried installing 18.04.5 three times (and used a new downloaded install image during the process) and always come to the same problem.

silly question… I’m assuming you are using windows as a host machine here… did you make sure to unblock the image before burning it? I’ve had issues with older images from Ubuntu because of this (they were zipped however)

Not sure what you mean about unblocking. I used balena etcher and it had no problems with installing (other than the Ethernet issue). I did manage to install 18.04.5 without reboot though. When it failed on the Ethernet connection, I tabbed up to the Ethernet adapter, manually selected it as DHCP, and it grabbed an IP address. However, after the install and a cold reboot, it failed to grab address again.

If it helps, this is what the response to the info command, before and after I selected DHCP during install…



1 Like