Ethernet connected wireless Modem keeps dropping out

Since the last update, my Ethernet wireless modem/bridge keeps dropping out. It is wirelessly connected to a wifi router that uses dialup internet. That is on a Radxa Zero 3E which I am trialing. I will purchase more if this fault can be remedied as it is a great board for a decent price for project work.

Seems like the “stay alive” internet signal has gone missing?
Modem starts and runs OK and then goes to sleep if not used for a few minutes!

The modem works flawlessly on other boards from other manufacturers and used to work OK before the update.

Any suggestions?

@Alvin please help to look into this issue

Can you post the kernel log?

Can you post the kernel log?

Not sure as there is no /var/log/kern.log file

tried to attach the dmesg and Xorg files but it only accepts image files

The USB disconnect on the last line is the USB key that I am using on this separate computer to xfer the files. The repeated install of eth0 is just me plugging and unplugging the modem to reset it. It goes down when I remove the power and comes up after plugging back in.

1 Like

It seems that it can check the insertion and disconnection of the network cable. Can you tell me which image you are currently using and what is the kernel version after the upgrade?

Can you tell me which image you are currently using and what is the kernel version after the upgrade?

Yes, see image files attached.
It is the standard Debian downloaded from Radxa.

I substituted a standard USB modem key “Edup” for the troublesome modem and now the Internet works perfectly, so problem solved for me! Thank you for your help.

Next, I noticed that Zram was already installed, which is nice.
This is a very polished and entirely workable effort, a credit to your crew!
Only thing missing is a RTC, I am spending the rest of the day trying out a dirt cheap I2C module I got from Aliexpress.

System clock could be faster, methinks. I ran an optical thermometer over the chips and they are all under 47C.

So problems solved and a great surprise for what I paid for it!
I have added a USB 3 extender hub, for convenience and testing.
I will add a backup UPS and some other trinkets in time as it is worth the effort.
When I next order 1 GBs next I will add one 4GB one for program development work.


This image did not load.
I am using the standard Xfce desktop.

:wink: If you have any questions, please feel free to contact us.