Error with rknn_toolkit1.3.2

I try to run rknn.init_runtime() but get RKNN_ERR_DEVICE_UNAVAILABLE

here is my environment

  • Debian 10
  • Python 3.7
  • Tensorflow 1.14.0
  • rknn_toolkit1.3.2

I run lsusb and get:
Bus 007 Device 004: ID 2207:0019 Fuzhou Rockchip Electronics Company

And I run rknn.list_devices() and get:
all device(s) with ntb mode:

I think NPU is power on, but the driver doesn’t match, is it?

Here is the full error message:

This looks like a hardware problem. Please post the dmesg.

thanks for the reply!
dmesg has too many texts, so I put in a text file.
Here is full dmesg. link

Thank you for your information. We’ll let you know when we identified the problem.

1 Like

I met exactly same problems on ubuntu 18.04 after recent apt upgrade.

Hi all, I solved this issue by install old version of rockchip-npu.

in 0.5 the ID 2207:1808 is missing, caused the problem.

1 Like

Thanks for the solution, so it looks like a driver issue.
I will try it on Debian10 later.

After downgraded to rockchip-npu 4.0,
I can run models on NPU now on Debian 10.

I have same problem on Debian 10 and board N10a
./rockx_head_detection test.jpg
E NPUTransfer: Cannot connect to proxy: Connection refused
E RKNNAPI: rknn_init, driver open fail! ret = -4(ERROR_NO_DEVICE)!
1600266171553 rockx load_model(74): rknn_init fail! ret=-3

1600266171559 rockx init(72): init module(9) error -1
Segmentation fault
root@rockpin10a:/home/rock# npu_powerctrl -i
init gpio: 4
Error writing to /sys/class/gpio/export value=4: Device or resource busy
gpio init
Downgrade to rockchip-npu 4.0 not help

root@rockpin10a:/home/rock# lsusb
Bus 008 Device 002: ID 2207:1808 Fuzhou Rockchip Electronics Company

What is problem?