Enabling tsadc on rock 4c+


I am trying to use the device tree blobs that are built using DTS checked in to the linux kernel sources. It works well for bluetooth, however, tsadc is disabled and because of this none of the thermal sensors work.

I tried creating some overlays shared by fellow forum member here, however, while GPU one seems to have worked, the ADC one did not.
Thing to note - if I try to do what that ADC overlay does by directly modifying source DTS, my Rock does not boot with resulting DTB file.

Apparently, something is in conflict, missing or incorrectly configured. I’d appreciate any hints on how to debug and fix the issue.


are you using latest dts file? last commit adds/enables tsadc.

Hello. No, I was using the one coming with kernel version that I use (6.1).

Let me try the latest one and get back.

Ok, I used DTS from the master branch and it seemed to have worked!
I can’t understand why the same change did not work for me through overlays.

Anyway, I can see the temperature now, and the rest of the peripherals I use work so far.