Enable MIDI on Rock Pi 4

Hello, I really need to get Alsa MIDI working but it looks like the Rock Pi kernel wasn’t compiled with CONFIG_SND_SEQUENCER enabled. I’m getting this output when typing aconnect

ALSA lib seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
can't open sequencer

Typing amidi -l returns

Dir Device    Name
cannot determine device number: Inappropriate ioctl for device

Please advise how I can get MIDI enabled without recompiling the kernel. I’m using a base Raspbian install with DietPi for what it’s worth. Thanks in advance.

1 Like

I am using Debian Buster on my Rock PI S.
Should I wait next OS img??
I don’t know how to build kernel…
Please make and upload new OS including this flag!!!
I need to work MIDI too!!!

You can try building Armbian image and change whatever you need on the way. It’s very simple: https://docs.armbian.com/Developer-Guide_Build-Preparation/

I sent a mail to support@radxa.com that ask to add the feature.
And I was just surprised to how fast I received email from support@radxa.com.

We will enable it in the next release. At the meantime, you can also
build the kernel package on your PC referring the following tutorial:


Now I am following the tutorial.
Great support!!!

Great customer support, indeed.

You will have less troubles with Armbian where you can build improved stock and improved modern v5.5.y kernel which has better software support measured in years. You can test this kernel by using armbian-config tool (system -> alternative kernel)

But for your use case probably anyone is good enough.

In case you haven’t got there yet, Armbian images and package upgrade has this feature already in.


Well… it’s my first kernel build and I am linux newbie.
So it shows me a lot of errors when I try “make -j8”.
After install gcc , python and … , the count of errors looks like decrease but still there.
I think I should install something more but I don’t know what it is…
So if I install Armbian image into my Rock PI S, can I use midi without kernel build??
And there are two Armbians, Buster and Bionic, what should I install??

Which is why Armbian is far better start for you.

Yes. Kernel dependencies were enabled, but I don’t have any gears to test if the feature actually works.

That depends on your software. Some prefer or need Ubuntu, some Debian. Both are the same in term of hardware support. They use identical kernel. Just pick one, perhaps Buster since its full version, while Bionic is a bit more stripped down.

Thank you very much.
Armbians looks better for me. Most of programs that I need are already installed!
But I can’t see my usb apc midi controller with “aconnect -l”.
Do you know how to mount or connect USB device??
“lsusb” shows me that there is “APC mini”.
Now I am just a plug and play guy. :sob::sob::sob:

Actually, I did it in my PC VirtualBox Debian . I mean I see “APC mini” with “aconnect -l” in PC Debian.
After install “alsa-utils”, it only works when I select “Device” > “USB” > “APC mini” in VirtualBox menu.

So I think there is some command thing can do “Device” > “USB” > “APC mini” in VirtualBox.
I think I don’t know that command.

Probably we missed something out. I have enable more / all stuff that is possible related. I hope that’s it.

apt update
apt upgrade

and try again.

1 Like

Oh. I just compared Rock PI S’s /boot/config and my PC Debian’s.
And I found there was difference.
For example.
CONFIG_USB_CONFIGFS_F_MIDI : Rock PI S (not set), PC Debian(Y)
CONFIG_SND_VIRMIDI : Rock PI S (not set), PC Debian(m)

I am not 100% sure but I think that these things need to set for usb midi controllers.
I think I notice this to support@radxa.com and I wait next OS…

Wow!!! It works!!! Thank you!!!
I didn’t “apt upgrade” because I thought it was same to “apt update”.
Now I can see “APC MINI” and MIDI works!!!

1 Like


That could take weeks :wink:

1 Like