eMMC Debian not booting, other OS are working fine


#1

Hi All

I just got my ROCK PI 4 MB 2Gb Basic Performance Set + eMMC 32Gb card and I’m playing around different OS images available for download on https://wiki.radxa.com/Rockpi4/downloads to check performances

I stumbled on a weird error, I can boot from eMMC every OS available except for Debian. I tried download and reimage the eMMC card multiple times but every time the same problem, when I plug in the power I see the light from the board, the lights from the lan cable but nothing on the screen, the monitor doesn’t get any signal at all. i waited minutes but nothing happens, no network…nothing
Same debian images works fine if booting from SD card so the issue seems to be only related to eMMC

I’m using rockpi4_debian_stretch_lxde_armhf_20181105_2120-gpt.img.gz and balenaEtcher-1.4.9.dmg to write the image from a MAC

Any Suggestion?? Am I missing something?

Thanks a lot


#2

Hi sushi80,

I have the same problem as you. I tried many methods, but they didn’t work.

I guess there’s something wrong with u-boot.

I boot the system from the microSD card, Install the latest u-boot (available in radxa-apt), dd it in the eMMC, unplug the microSD card, and reboot.

It works.


#3

Interesting, I’ll give it a try!

Thanks for the tip! I’ll let you know how it goes