eMMC Android Rock Pi 4C Plus


I’m trying to run Android on my Rock Pi 4C Plus from eMMC. Following the docs from https://wiki.radxa.com/Rockpi4/install/eMMC in order to flash my Android image, which worked (I can see the numerous partitions created on the eMMC drive). Once powering it back again, nothing at all is happening. The green led obviously shows up, but nothing I would expect after that (mo blue light flashing.

I tried to hook up pin 23 to pin25 from the GPIO connector, without success, and I<m a little bit confused on what to do next.

Any clue?

Thanks !

Dear Christian,

I don’t have a Rock 4C but I can share my instructions that I’m using on my Rock 5b.
Download a latest stable Debian Linux image and flash it to an sdcard and boot from it.
Flash your Android image to EMMC using BalenaEtcher for ARM and restart without sdcard.
By the way I’m using GPT images, not update.img.

No need to unplug the EMMC from 4C just for flashing it, you can damage it easily.


It worked perfectly. How come it’s not part of the documentation. So simple and efficient ! :slight_smile:

Many thanks!