E25 - Boot Loop

I’m using a newly flashed SD card (same result for both debian and ubuntu images) on an Radxa E25 board. Only when plugged into my laptop via USB C does it boot successfully, all other times (5 different power supplies tried, including one designed to charge the laptop itself) the unit’s lights will turn green, then off, then green, then off repeatedly.

I can connect via serial console (115200 baud rate), but can never identify what causes the boot loop.

Can anyone please advise a solution or at least some troubleshooting steps?


Got the same problem and managed to work around this using an USB-C power-supply. I can connect to the device using ssh afterwards.

Unfortunately I have not found a way to boot the device in a usable mode and use the serial console yet.

@giggls Ironically it is ONLY when I connect via my computer’s USB port that I can run the device without a boot loop. so I CAN connect over serial.

After the last few days I’ve had SOME success with other devices (if left long enough, it seems to boot stable, but only after cycling a handful of times.)

is there any info I could collect from the boot logs that could help identify the issue?

I think you got me wrong. You need more current than an average USB-Port can supply thus you can not connect the console to work.

Thus it works for me without connecting the console only as I don’t know how to supply enough current and using the serial console at the same time.

You need to use a usbc power brick with power delivery… Otherwise you’ll get a boot loop…

@Alvin pointed me to this solution.

Oooh and to get serial console and power over the same port… I use a usbc hub with power delivery input attached to my laptop… It gets the power it needs and it shows up as a serial service for watching the boot sequence…

Same sort of problem for me, sorted with a proper PD psu. I was trying to power my rock3a with a regulated ‘bench’ 5v supply which just ended up with consistent boot failures and boot loops.

With Radxa 5V 6A PSU, my E25 boots OpenWRT, refuses to boot Debian or Ubuntu. With 5V 2A Xiaomi PSU, boots any OS just fine.

Use the xiaomi brick usb pd? The radxa 30w pd brick works fine for all the OSes I’ve tried sofar… Ive run both Deb and Ubuntu on it so far…

@Jameszy both Xiaomi and Radxa PSUs I use are dumb non-PD. Here’s Allnet link to the Radxa one. It works fine with Rock 5B.

I also have a bunch of PD bricks, but they all provide 3A max on 5V, and I highly doubt that is enough for E25 + MT7915 AP WLAN card + LTE modem.