Debian WiFi not working

Downloaded a Debian image from

Using the 1GB model, cannot find the option to change the nmcli STATE from disconnected to connected.

Is another WiFi driver required or is the 1GB Radxa Zero just not compatible?

No, we do not need another WiFi driver.

You can use nmcli tool to connect WiFi to AP. If it succeed, then the state would change from disconnected to connected.

I came across the same situation.
I found error in dmesg as “brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.bin failed with error -2”.

So I copied ‘’ to /lib/firmware/brcm.
It worked following ‘’.

I repeated what you tried and pulled the file from
Sadly same result. I suspect because of the 1GB external model uses WiFi AP6212

nmcli con add type wifi ifname wlan0 mode ap con-name test ssid test ipv4.method shared

Device shows as – so still no WiFi wlan0 is accessible.

That’s too bad. My zero is with 512MB and AP6212, though the hardware not so much different from your’s.
Is there no wlan0 by command ‘ip address’ ?

Regarding firmware, brcmfmac43430-sdio.bin and brcmfmac43430-sdio.txt seem to be needed.

1 Like

That was the trick. Thank you

I have 4gb version and ap6256 and I cannot seem to get wifi up even with brcmfmac43456-sdio.bin and txt

[    8.595614] brcmfmac: brcmf_chip_get_raminfo: RAM size is undetermined        
[    8.596526] brcmfmac: brcmf_sdio_probe_attach: brcmf_chip_attach failed!      
[    8.605014] brcmfmac: brcmf_sdio_probe: brcmf_sdio_probe_attach failed        
[    8.609765] brcmfmac: brcmf_ops_sdio_probe: F2 error, probe failed -19...

The chip says ap6256 on the hardware.

Great. We’ll add these two files to the next release images.

The released image contains AP6256 firmware by default. You don’t need to copy the fw for it.

root@zero:~# ls /lib/firmware/brcm/
BCM4345C5.hcd  brcmfmac43456-sdio.bin  brcmfmac43456-sdio.txt

Looks like a hardware issue. Can you do the following trouble shooting for WIFI Module circuit?

  • Use an oscilloscope to check the frequency of the crystal oscillator
  • Check the frequency of network ‘RTC_CLKO_WIFI’ (32768Hz)
  • Check the voltage of power supply

You can get the hardware files from here,

Someone from the discord chat informed me about the kernel patch needed.

I will try again with this patch and inform later.

Update the kernel patch fixed the wifi.
Kernel is updated on Manjaro ARM unstable branch and it is also merged in 5.15-rc5.