Debian-testing/debian-stable public.key has expired

Hello, just something I noticed while updating my Rock 5 today. I’m running the Bullseye release provided by Radxa and it appears that I’m getting an error when trying to update from either of the apt repositories (testing/stable), indicating that there is no valid signature (The following signatures were invalid: EXPKEYSIG B99C4BEFEC47E96E Radxa

Further investigation listing the keys with apt-key list, has shown this to be correct:

pub rsa3072 2020-11-24 [SC] [expired: 2022-11-24]
*** 466B 1E7F 6809 6652 1384 8FCA B99C 4BEF EC47 E96E***
uid [ expired] Radxa


Attempting to manually re-add the public keys from the repositories, as well as the github ones, yield the same (expired) key.



Yes, i had the same experience.

Updating the gpg key now…

1 Like

HI Jack,
I’ve got this error:
Err:2 bullseye Release
404 Not Found [IP: 80]

Thank you

1 Like

Same problem has occurred on the Ubuntu public key.

Hi jack, it seem that public key is not available again

same here

Err:5 bullseye InRelease                                                                                                                                              
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9B98116C9AA302C7
Reading package lists... Done                                                                                                                                                                              
W: GPG error: bullseye InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9B98116C9AA302C7
E: The repository ' bullseye InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

had to temporarily skip security check by putting [trusted=yes] in front of the repository to be able to update

@jack Any update as to when this might be fixed? Cheers

Been a problem for a few days now. Raxda is not very responsive!

on my system I retrieved the new public key with

export DISTRO=bullseye-stable
wget -O -$DISTRO/public.key | sudo apt-key add -


Any resolution on this issue? I continue to have GPG errors even when attempting to import the key from the Radxa GitHub repo.

the solution of @lurk101 just UP your post did the job for me.
Thanks @lurk101 !

Didn’t work for me:
/home/pi ➜ sudo wget -O -$DISTRO/public.key 2 | sudo apt-key add - [22/12/1| 4:53PM] pi radxa5-1
[sudo] password for pi:
–2022-12-01 16:54:16--
Resolving (…,,, …
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1290 (1.3K) [application/]
Saving to: ‘STDOUT’

  •                                 100%[=======================================================================>]   1.26K  --.-KB/s    in 0s      

2022-12-01 16:54:17 (82.7 MB/s) - written to stdout [1290/1290]

–2022-12-01 16:54:17-- http://2/
Resolving 2 (2)…
Connecting to 2 (2)||:80… Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
failed: Connection timed out.

–2022-12-01 16:56:26-- (try: 2) http://2/
Connecting to 2 (2)||:80… failed: Connection timed out.

Remove the 2 after the URL. The forum adds the # of clicks to a URL so you accidentally copied that, the proper format should look like,

That did it, thanks

Yes it works but after that, if you do “apt upgrade” the system won’t boot anymore. I can’t understand why it appens, ubuntu should be an official distro… mah!
Anyone as me?

After sitting on my rockpi 5 for over a month I finally tried to get it up and running. Once installing new public.key and sudo apt upgrade after reboot it seems it doesn’t want to connect to monitor. I was still able to ssh though. Anyone else have this problem?

Me too, same problem. Tried several times, same result every time.
I am very disappointed, ubuntu is an official distro… or so it seems to be.

Didn’t work for me either all I got was:
wget -o : command not found
I tried with a capital O lower case o and 0 (zero)
man shows it with a O .

worked for me -
For Debian Stretch

wget -O - | sudo apt-key add - 

Edit your /etc/apt/sources.list and add the following:

deb stretch main