Debian HDMI sound

According to the Radxa debian audio section - hdmi sound is currently not working. So, you have to use a USB audio device. Any idea when the hdmi sound will be working? It’s a great little board once you get things installed correctly.


1 Like

I’ve only tested this on my own custom imgs, but I hear it works with the Radxa ones as well. Create a script and service or add this to /etc/rc.local. Don’t forget to include the sleep.

sleep 15s
amixer sset 'FRDDR_A SINK 1 SEL' 'OUT 1'
amixer sset 'FRDDR_A SRC 1 EN' 'on'
amixer sset 'TDMOUT_B SRC SEL' 'IN 0'
amixer sset 'TOHDMITX I2S SRC' 'I2S B'
amixer sset 'TOHDMITX' 'on'
amixer sset 'FRDDR_B SINK 1 SEL' 'OUT 2'
amixer sset 'FRDDR_B SRC 1 EN' 'on'
amixer sset 'FRDDR_C SINK 1 SEL' 'OUT 3'
amixer sset 'FRDDR_C SRC 1 EN' 'on'

Tested your settings on the debian image no luck.

hmm. Worked fine for me. Did you try running it in a terminal whilst logged in?

I hooked it up to my 7 inch hmdi touch screen and sshd’d in to setup rc.local with vim and rebooted then hoooked up my mouse and tried to watch a youtube video but had no sound. I went into a terminal and typed aplay -l but no soundcard found. I tried to run alsamixer but nothing is found either.

Oh. That’s not very good. I didn’t realize aplay wasn’t showing anything? I haven’t personally used the imgs provided by Radxa and was going off what another user told me when I suggested they used the settings.

uname -a; aplay -l
Linux rzero 5.16.5 #1 SMP PREEMPT Tue Feb 1 17:04:24 UTC 2022 aarch64 GNU/Linux
**** List of PLAYBACK Hardware Devices ****
card 0: RADXAZERO [RADXA-ZERO], device 0: fe.dai-link-0 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: RADXAZERO [RADXA-ZERO], device 1: fe.dai-link-1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: RADXAZERO [RADXA-ZERO], device 2: fe.dai-link-2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

thanks for the help =) im sure it will be sorted out soon.

Yeah it does say

actually HDMI audio is currently not working. This is a known issue. Alternatively you can connect to a USB sound card. Or even better, a USB speaker, which has integrated USB sound card inside. In this guide we will show you how to play sound on your USB speaker using Radxa Zero.

The Rock3a seems the same dunno if its hardware or software but yeah seems like it doesn’t work as never did test hdmi audio

There was this but the wiki would prob show the fix so likely not as above

Maybe @chewitt might know?

Zero audio works fine; as long as you have an alsa conf and apply mixer settings from userspace. LE has all the prior art required in its repo.


I guess I need a little more to go on. Maybe, a simple script that I can start when the board boots?

I have it working with rotating the screen on my 5" inch display, autologin, starting my application, doing midi, playing soundfonts, and getting sound through a usb sound card - just not the HDMI audio port.

You need sound service script to start on boot.
Hdmi audio works on manjaro.

1 Like

OK. I took the script from LE, but when I try to execute it I get:

./ line 133: dtsoc: command not found

What is dtoc and how can I install it?

Maybe another script but what it shows a just amixer commands.

Install the alsalibs libasound2…

Use the settings to just manually set amixer and give it a test.
If it works just create your own little script or something or get a fresh manjaro image… ?

OK. This is what is showing up in pavucontrol after running the script with amixer commands from above post.

So, now, it is at least showing an audio device, which it wasn’t before. But, when I run the speaker-test - I see that the sound is showing in the pavucontrol, but I still don’t hear anything.

Dunno start with alsa as pulseaudio sits ontop.

See if you can get a cmdline aplay to work before you get to pulseaudio and desktops

OK. It’s something to do with my 5" screen. Sound works just fine when I attach it to my HDMI on the TV. Thanks. Now, it looks like my problem.

1 Like

Here’s the weird thing. I plug in my RPi4B, which is running Rasbian (derivative of debian). The HDMI audio output works just fine with the 5" inch display.

So, a difference I see is the RPi4B is using Audio Digital and not Audio Analog as my pictures above show on the Radxa Zero.

OK. I did another test with my HDMI TV. It has 2 RCA jacks to a 4-pole stereo audio plug, which I plug in to our soundbar. Disconnect 1 RCA jack and no sound. So, these settings described above (which work) only do mono sound. How do we do stereo sound? Maybe, that’s why it’s not working with the 5" inch HDMI display. I have a stereo jack plugged in. I’m pulling at straws here. Any suggestions?

This cockamamie setup works. Why did I have to connect a stereo plug that goes to 2 RCA plugs to Behringer U-Control UCA202 and then plug that via the UCA202 headphone jack to my soundbar and it works?

“The UCA202 provides 2 analog inputs and outputs, as well as an additional S/PDIF optical output for direct digital conversion. The stereo headphone output with dedicated level control lets you monitor both input and output.”

This is frustrating!

OK. I booted up Mangaro xfce and the sound works (but no wifi). So, I copied down all of the alsamixer configurations for radxa-zero. I booted up debian, again, and applied all of the settings from manjaro to debian through alsamixer.

I did: pulseaudio -k and then pulseaudio --start and all of a sudden the speaker-test started to play via my 5" screen.

BUT, when I bring up the pavucontrol screen it is stuck in "Establishing connection to PulseAudio. Please wait…

So, slow progress.

1 Like