Debian forgets all screen resolutions but 3840x2160

If I switch off and on the monitor (same issue on a 4K TV…) the custom resolution I chosed is forgotten and gets ALWAYS restored to 3840x2160… :persevere:

What do I have to do please to LOCK the screen resolution to 2560x1440?

Could you try with xrandr?
For you it should be something like :
xrandr --output HDMI-1 --mode 2560x1440 --rate 60
I think you’re going to need to add it to a bash file, but I have no clue where the display resolution is set here. Haven’t found a config file yet.

1 Like

I am in the same boat that’s why I was asking hehe. :sweat_smile:

All the solutions found on Internet didn’t apply to this Debian image…

@jack ? @hipboi? Radxa people? Anybody of you caring to help me please?

The screen resolution should be remembered. It should be stored in the $HOME folder of the current user. I will check exactly which configuration file is stored.

Thanks appreciated. :+1:t3:


From my test, if you set the resolution in Menu -> Preference -> Monitor Setting, the resolution will be saved. It’s stored at ~/.config/autostart/lxrandr-autostart.desktop

After reboot, the lxrandr will be executed to restore your last time resolution.

Another command to check the actual resolution from the low level.

cat /sys/class/drm/card0-HDMI-A-1/mode


If at 2560x1440 then cat command gives me

cat /sys/class/drm/card0-HDMI-A-1/mode

, but no matter what I do (rebooting or shutting down) it keeps resetting to 3840x2160 (if I switch off/on the monitor). :tired_face:

What is the file with all the resolutions set?
I thought that leaving only the 2560x1440 screen resolution might do the trick?


We can reproduce this issue and we have fix now. I will let you know how to fix it once we test it ok.


Alright thanks for taking care! :+1:t3:


To fix the resolution issue, you can install the newer rockchip-overlay package from

sudo apt-get install rockchip-overlay

and remove the old drm trigger

rm /etc/udev/rules.d/hdmi.rules
rm /usr/local/bin/hdmi-toggle

Thank you! :heart_eyes:

Did it like 5 minutes ago and so far so good!