CSI Camera for Rock 3A

I have a skepticism on Radxa product marketing regarding this title.
During this three months, I saw several requests for CSI camera for the Rock 3A, However I didn’t see any answer from Radxa. Usually, I think if manufacturers announce their new products , they provide us with the solution for their key features. I think the CSI camera for the Rock 3A is one of key features especially related to NPU.
Recently I’m looking forward to your new product the ROCK 5B and I would like to get it. As you know , the product has the CSI interface, I strongly hope this issue would be solved before the official order process for the Rock 5B starts.

1 Like

We’ve selected IMX415 for the 5B and zero2. There will be official camera module from Radxa. For 3A, the issue is, the sensor widely available on the market(ov5640/imx219) are not tuned(ISP support) on rk356x platform. I think we should support imx219 first, then tune the ISP with the help from Rockchip.

Thank you for your quick reply.
I’m afraid the IMX415 is more expensive than the IMX219. Hopefully, the IMX219 or OV564x is the best because many users already have them.
However, I think fast availability should be important.

1 Like

Sorry if this is not the best place to ask, but, is there ANY documentation about how to use the CSI port? I couldn’t find nothing at all about it, I use rpi4 in the past with raspivid, but not sure how to start with the rock3a.


I think there is some support for ov4689 (from rockchip / some other maker) at least for rk3399 with reasonable results and it is a two-lane. Used to be moderately priced (better than imx219). Is it hard to source this sensor or there are some other limitations?

I have solved CSI camera ov5647 on board rock3a, you need to modify both rock3a’s dtb and ov5467 kernel driver.

Hi, abel.
Thank you for your nice comment.
Next, please tell me the detailed procedure.
Thank you.

I modify something about dtc code and ov5674 driver code, here are more details:


Thank you for the great work.
I will give it a try.

Sure thing! I’ll be happy to help. :grin:

Hi, I am having the same issue. Have you been able to figure it out? Any help will be appreciated.