Compiled Android 9 TV does not boot

Hello! I compiled Android 9 TV Box following steps from README at https://github.com/radxa/manifests. Everything seems to build without issues (sources checkout, compilation, image building). I flashed gpt.img to the SD card, and my Rock PI 4B v1.4 is booting. At first boot it shows “Erasing” screen, then it restarts and I see Android TV boot animation. Unfortunately, after several minutes of playing animation it restarts and goes to the recovery. I have two options - “Try again” and “Factory reset”. Does not have access to the ADB logs so far - My PC does not detect Rock Pi when I use USB A to USB C cable (OTG switch is at Device position) and I am waiting for shipment of USB A to USB A cable. Tried different SD card but effect is the same - recovery menu after some time.

When I download Android 9 image from Rock PI site and flash it on the SD card it works fine.

Does anyone compiled Android 9 TV Box from sources recently and can confirm that everything works? Thanks in advance.

It worked for me last time I ran it a couple of weeks ago.