CM3 with BIGTREETECH PI4B adapter

I managed to install debian bullseye on the radxa CM3 (D2E16W2) on the EMMC. I can see bluetooth, I can see USB, I can use HDMI with a wide screen, and the wired ethernet works just fine, but I cannot find a way to use it with wifi. any suggestion?

I’m trying to get my CM3 working on a BTT Pi4B too, but didn’t manage to boot it yet. Only tried via SD card though. Did you do anything special to get it running?

I lollowed this instructions:

also, at one point, you need to use 2 of the switches on the biqu board. fot them, I used the biqu manual and considered my CM3 as a raspberry pi CM4.
in detail, you need to use the SW RKDEVTOOL and load the bootloader

the RKDevTool is not easy to use, I tried different things (as in the manual) until I got it to work. what I intend to do is to try again and write down the precise steps to follow, as soon as I have a new board to flash (the first one is under test right now)

hope this help


Thank you for the reply! Looks like my problem lies somewhere else than, because I can’t even get my PC to recognize the CM4. Linux/RKDEVTOOL won’t list any IDs. Did you have to do anything special to make sure the board is powered on properly?

sorry for the late reply. you have to power on while pressing the button. the button is very small and tricky to keep pressed, be sure to feel the clic.
did you manage to solve your problem?


I was able to put a CM3 onto the BTT PI4B adapter and write both official images (Debian and Ubuntu) to the EMMC and boot either. For me, with either image, networking worked flawlessly so I was able to connect to the system over SSH, however I did not get any HDMI output; USB is not working as well.

When I move the board to the official Radxa CM3 IO board, everything works perfectly (HDMI, USB, etc.) I thought it might be related to the loaded device tree, so I followed the guide on the OS image download page, and replaced the rk3566-radxa-cm3-io.dtb with rk3566-radxa-cm3-rpi-cm4-io.dtb. Still, I have no USB and HDMI on the PI4B adapter. HDMI is not critical as I intend to use the CM3 as a host for a 3D printer, but USB is essential to connect to the printer and USB cam.

@luca, is USB working for you and if yes, how did you manage to make it work?


That’s kinda weird. I’m currently using the CM3 on a BTT Manta M8P and got everything (HDMI, USB) working except DSI. I was using the official Ubuntu Server version on the Github page and did not change anything dtb related.