CM3 compatible boards with working USB?

I saw in another thread that people don’t have luck with waveshare io board, I tried the methods in the thread and nothing seems to work. I tried to ground pin 101 as well but it didn’t help for me.

I’ve tried the same CM3 on:
Waveshare CM4 to 4B adapter
Spotpear CM4 to 4B adapter
Piunora & Piunora lite
Radxa CM3 io board

The only device with working usb is Radxa CM3 io board. Does anyone have any success outside of Radxa devices? I tried both linux and android images.

If you use the cm3-io images from here :

you can enable usb with a little trick
connect to it via ssh and do this :

chmod +x usb.service
systemctl enable usb

this will install a service which will enable usb on each boot.
The newer images :
won’t work with that hack

1 Like

Not sure if I’m doing anything wrong but I tried the images from debos-radxa and still does not work. It looks like the usb services just runs the otg_mode setting.

That’s all that is needed (at least on my board)

You can also do the solder way, it’s discribed here :slight_smile:CM3 + CM4-IO-BASE-B(Waveshare)

I just want to report back that I had to switch to CM4 dtb as per instructions of the newer repo after installing from debos-radxa repo. I’m just glad I don’t have a paper weight.

Hi Raphael,

I’ve tried the method you said but when doing systemctl enable usb, the message that I’m getting back is the following:
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ===
Authentication is required to manage system service or unit files.
Authenticating as: rock, (rock)
Failed to enable unit: Unit file usb.service does not exist.

I’m using the following image radxa-cm3-io-debian-bullseye-xfce4-arm64-20230201-1123-gpt.img.xz

Glad is someone can help me with this topic.

Many thanks,



sudo systemctl enable usb

Hi Raphael, same output. Failed to enable unit: Unit file usb.service does not exist.

long time ago where I wrote the post :slightly_smiling_face:… let’s do it this way:

sudo -s
cd /etc/systemd/system/
chmod +x usb.service
systemctl enable usb

this should work

Perfect! This is working!

Many thanks!